cSapModel Interface

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
public interface cSapModel

The cSapModel type exposes the following members.

Properties
Methods
  NameDescription
Public methodGetDatabaseUnits
Returns a value from the eUnits enumeration indicating the database units for the model. All data is internally stored in the model in these units and converted to the present units as needed.
Public methodGetDatabaseUnits_2
Retrieves the database units for the model. All data is internally stored in the model in these units and converted to the present units as needed.
Public methodGetMergeTol
Public methodGetModelFilename
Returns a string that represents the filename of the current model, with or without the full path.
Public methodGetModelFilepath
Returns the filepath of the current model
Public methodGetModelIsLocked
Public methodGetPresentCoordSystem
Public methodGetPresentUnits
Returns a value from the eUnits enumeration indicating the units presently specified for the model.
Public methodGetPresentUnits_2
Retrieves the units presently specified for the model
Public methodGetProjectInfo
Retrieves the project information data.
Public methodGetVersion
Returns the program version.
Public methodInitializeNewModel
This function clears the previous model and initializes the program for a new model. If it is later needed, you should save your previous model prior to calling this function.
Public methodSetMergeTol
Public methodSetModelIsLocked
Locks or unlocks the model.
Public methodSetPresentUnits
Sets the display (present) units.
Public methodSetPresentUnits_2
Specifies the units for the model
Public methodSetProjectInfo
Sets the data for an item in the project information.
Public methodTreeIsUpdateSuspended
Public methodTreeResumeUpdateData
Public methodTreeSuspendUpdateData
Top
See Also