cFrameObjGetPoints Method

Retrieves the names of the point objects at each end of a specified frame object.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetPoints(
	string Name,
	ref string Point1,
	ref string Point2
)

Parameters

Name
Type: SystemString
The name of a defined frame object.
Point1
Type: SystemString
The name of the point object at the I-End of the specified frame object.
Point2
Type: SystemString
The name of the point object at the J-End of the specified frame object.

Return Value

Type: Int32
Returns zero if the point names are successfully retrieved, otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
   Dim SapModel As cSapModel
   Dim EtabsObject As cOAPI
   Dim ret As Integer = -1
   Dim Point1 As String
   Dim Point2 As String

'create ETABS object
   EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

'start ETABS application
  ret = EtabsObject.ApplicationStart()

'create SapModel object
   SapModel = EtabsObject.SapModel

'initialize model
   ret = SapModel.InitializeNewModel()

'create steel deck template model
   ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)

'get names of points
   ret = SapModel.FrameObj.GetPoints("3", Point1, Point2)

'close ETABS
   EtabsObject.ApplicationExit(False)

'clean up variables
   SapModel = Nothing
   EtabsObject = Nothing

End Sub
See Also