cAnalysisResultsJointAcc Method

Reports the joint accelerations for the specified point elements. The accelerations reported by this function are relative accelerations.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int JointAcc(
	string Name,
	eItemTypeElm ItemTypeElm,
	ref int NumberResults,
	ref string[] Obj,
	ref string[] Elm,
	ref string[] LoadCase,
	ref string[] StepType,
	ref double[] StepNum,
	ref double[] U1,
	ref double[] U2,
	ref double[] U3,
	ref double[] R1,
	ref double[] R2,
	ref double[] R3
)

Parameters

Name
Type: SystemString
The name of an existing point object, point element, or group of objects depending on the value of the ItemTypeElm item.
ItemTypeElm
Type: ETABS2016eItemTypeElm
This is one of the following items in the eItemTypeElm enumeration.

If this item is ObjectElm, the result request is for the point element corresponding to the point object specified by the Name item.

If this item is Element, the result request is for the point element specified by the Name item.

If this item is GroupElm, the result request is for all point elements directly or indirectly specified in the group specified by the Name item.

If this item is SelectionElm, the result request is for all point elements directly or indirectly selected and the Name item is ignored.

NumberResults
Type: SystemInt32
The total number of results returned by the program.
Obj
Type: SystemString
Elm
Type: SystemString
LoadCase
Type: SystemString
This is an array that includes the name of the analysis case or load combination associated with each result.
StepType
Type: SystemString
This is an array that includes the step type, if any, for each result.
StepNum
Type: SystemDouble
This is an array that includes the step number, if any, for each result.
U1
Type: SystemDouble
This is a one dimensional array that includes the translational acceleration in the point element local 1 direction for each result. [L/s2]
U2
Type: SystemDouble
This is a one dimensional array that includes the translational acceleration in the point element local 2 direction for each result. [L/s2]
U3
Type: SystemDouble
This is a one dimensional array that includes the translational acceleration in the point element local 3 direction for each result. [L/s2]
R1
Type: SystemDouble
This is a one dimensional array that includes the rotational acceleration in the point element local 1 direction for each result. [rad/s2]
R2
Type: SystemDouble
This is a one dimensional array that includes the rotational acceleration in the point element local 2 direction for each result. [rad/s2]
R3
Type: SystemDouble
This is a one dimensional array that includes the rotational acceleration in the point element local 3 direction for each result. [rad/s2]

Return Value

Type: Int32
Returns zero if the accelerations are successfully recovered, otherwise it returns a nonzero value
Remarks
See Results for more information.
Examples
VB
Public Sub Example()
Dim ret As Integer = -1

    Dim MyLoadType() As String
    Dim MyLoadName() As String
    Dim MyFunc() As String
    Dim MySF() As Double
    Dim MyTF() As Double
    Dim MyAT() As Double
    Dim MyCSys() As String
    Dim MyAng() As Double

    Dim NumberResults As Integer
    Dim Obj() As String
    Dim Elm() As String
    Dim LoadCase() As String
    Dim StepType() As String
    Dim StepNum() As Double
    Dim U1() As Double
    Dim U2() As Double
    Dim U3() As Double
    Dim R1() As Double
    Dim R2() As Double
    Dim R3() As Double

'initialize model
    ret = mySapModel.InitializeNewModel()

'create steel deck template model
    ret = mySapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)

'add linear modal history load case
    ret = mySapModel.LoadCases.ModHistLinear.SetCase("MyMHLCASE1")

'set load data
    ReDim MyLoadType(1)
    ReDim MyLoadName(1)
    ReDim MyFunc(1)
    ReDim MySF(1)
    ReDim MyTF(1)
    ReDim MyAT(1)
    ReDim MyCSys(1)
    ReDim MyAng(1)
    MyLoadType(0) = "Load"
    MyLoadName(0) = "DEAD"
    MyFunc(0) = "RAMPTH"
    MySF(0) = 1
    MyTF(0) = 1
    MyAT(0) = 0
    MyCSys(0) = "Global"
    MyAng(0) = 0
    MyLoadType(1) = "Accel"
    MyLoadName(1) = "U2"
    MyFunc(1) = "UnifTH"
    MySF(1) = 2
    MyTF(1) = 1.5
    MyAT(1) = 10
    MyCSys(1) = "Global"
    MyAng(1) = 10
    ret = mySapModel.LoadCases.ModHistLinear.SetLoads("MyMHLCASE1", 2, MyLoadType, MyLoadName, MyFunc, MySF, MyTF, MyAT, MyCSys, MyAng)

'run analysis
    System.IO.Directory.CreateDirectory("c:\CSI_API_temp")
    ret = mySapModel.File.Save("C:\CSI_API_temp\example.edb")
    ret = mySapModel.Analyze.RunAnalysis()

'deselect all cases and combos
    ret = mySapModel.Results.Setup.DeselectAllCasesAndCombosForOutput()

'set case selected for output
    ret = mySapModel.Results.Setup.SetCaseSelectedForOutput("MyMHLCASE1")

'set modal history output option to step-by-step
    ret = mySapModel.Results.Setup.SetOptionModalHist(2)

'get joint acceleration
    ret = mySapModel.Results.JointAcc("All", eItemTypeElm.GroupElm, NumberResults, Obj, Elm, LoadCase, StepType, StepNum, U1, U2, U3, R1, R2, R3)

'check
    If NumberResults > 0 Then ret = 0 Else ret = -1

'close application
    mySapObject.ApplicationExit(False)

'clean up variables
    mySapModel = Nothing
    mySapObject = Nothing
   End Sub
See Also