cAnalysisResultsBaseReactWithCentroid Method |
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint BaseReactWithCentroid(
ref int NumberResults,
ref string[] LoadCase,
ref string[] StepType,
ref double[] StepNum,
ref double[] FX,
ref double[] FY,
ref double[] FZ,
ref double[] MX,
ref double[] ParamMy,
ref double[] MZ,
ref double GX,
ref double GY,
ref double GZ,
ref double[] XCentroidForFX,
ref double[] YCentroidForFX,
ref double[] ZCentroidForFX,
ref double[] XCentroidForFY,
ref double[] YCentroidForFY,
ref double[] ZCentroidForFY,
ref double[] XCentroidForFZ,
ref double[] YCentroidForFZ,
ref double[] ZCentroidForFZ
)
Function BaseReactWithCentroid (
ByRef NumberResults As Integer,
ByRef LoadCase As String(),
ByRef StepType As String(),
ByRef StepNum As Double(),
ByRef FX As Double(),
ByRef FY As Double(),
ByRef FZ As Double(),
ByRef MX As Double(),
ByRef ParamMy As Double(),
ByRef MZ As Double(),
ByRef GX As Double,
ByRef GY As Double,
ByRef GZ As Double,
ByRef XCentroidForFX As Double(),
ByRef YCentroidForFX As Double(),
ByRef ZCentroidForFX As Double(),
ByRef XCentroidForFY As Double(),
ByRef YCentroidForFY As Double(),
ByRef ZCentroidForFY As Double(),
ByRef XCentroidForFZ As Double(),
ByRef YCentroidForFZ As Double(),
ByRef ZCentroidForFZ As Double()
) As Integer
int BaseReactWithCentroid(
int% NumberResults,
array<String^>^% LoadCase,
array<String^>^% StepType,
array<double>^% StepNum,
array<double>^% FX,
array<double>^% FY,
array<double>^% FZ,
array<double>^% MX,
array<double>^% ParamMy,
array<double>^% MZ,
double% GX,
double% GY,
double% GZ,
array<double>^% XCentroidForFX,
array<double>^% YCentroidForFX,
array<double>^% ZCentroidForFX,
array<double>^% XCentroidForFY,
array<double>^% YCentroidForFY,
array<double>^% ZCentroidForFY,
array<double>^% XCentroidForFZ,
array<double>^% YCentroidForFZ,
array<double>^% ZCentroidForFZ
)
abstract BaseReactWithCentroid :
NumberResults : int byref *
LoadCase : string[] byref *
StepType : string[] byref *
StepNum : float[] byref *
FX : float[] byref *
FY : float[] byref *
FZ : float[] byref *
MX : float[] byref *
ParamMy : float[] byref *
MZ : float[] byref *
GX : float byref *
GY : float byref *
GZ : float byref *
XCentroidForFX : float[] byref *
YCentroidForFX : float[] byref *
ZCentroidForFX : float[] byref *
XCentroidForFY : float[] byref *
YCentroidForFY : float[] byref *
ZCentroidForFY : float[] byref *
XCentroidForFZ : float[] byref *
YCentroidForFZ : float[] byref *
ZCentroidForFZ : float[] byref -> int
Parameters
- NumberResults
- Type: SystemInt32
- LoadCase
- Type: SystemString
- StepType
- Type: SystemString
- StepNum
- Type: SystemDouble
- FX
- Type: SystemDouble
- FY
- Type: SystemDouble
- FZ
- Type: SystemDouble
- MX
- Type: SystemDouble
- ParamMy
- Type: SystemDouble
- MZ
- Type: SystemDouble
- GX
- Type: SystemDouble
- GY
- Type: SystemDouble
- GZ
- Type: SystemDouble
- XCentroidForFX
- Type: SystemDouble
- YCentroidForFX
- Type: SystemDouble
- ZCentroidForFX
- Type: SystemDouble
- XCentroidForFY
- Type: SystemDouble
- YCentroidForFY
- Type: SystemDouble
- ZCentroidForFY
- Type: SystemDouble
- XCentroidForFZ
- Type: SystemDouble
- YCentroidForFZ
- Type: SystemDouble
- ZCentroidForFZ
- Type: SystemDouble
Return Value
Type:
Int32
See Also