cPropFrameGetAutoSelectSteel Method

Retrieves frame section property data for a steel auto select lists.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetAutoSelectSteel(
	string Name,
	ref int NumberItems,
	ref string[] SectName,
	ref string AutoStartSection,
	ref string Notes,
	ref string GUID
)

Parameters

Name
Type: SystemString
The name of an existing auto select section list–type frame section property.
NumberItems
Type: SystemInt32
The number of frame section properties included in the auto select list.
SectName
Type: SystemString
This is an array of the names of the frame section properties included in the auto select list.
AutoStartSection
Type: SystemString
This is either Median or the name of a frame section property in the SectName array. It is the starting section for the auto select list.
Notes
Type: SystemString
The notes, if any, assigned to the section.
GUID
Type: SystemString
The GUID (global unique identifier), if any, assigned to the section.

Return Value

Type: Int32
Returns zero if the data is successfully retrieved; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim MyName() As String
       Dim NumberItems As Integer
       Dim SectName() As String
       Dim AutoStartSection As String
       Dim Notes As String
       Dim GUID As String

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'set new frame section properties
       ret = SapModel.PropFrame.SetAngle("ANGLE1", "A992Fy50", 6, 4, 0.5, 0.5)
       ret = SapModel.PropFrame.SetAngle("ANGLE2", "A992Fy50", 5, 3, 0.4, 0.4)
       ret = SapModel.PropFrame.SetAngle("ANGLE3", "A992Fy50", 4, 2, 0.3, 0.3)

   'set new auto select list frame section property
       ReDim MyName(2)
       MyName(0) = "ANGLE1"
       MyName(1) = "ANGLE2"
       MyName(2) = "ANGLE3"
       ret = SapModel.PropFrame.SetAutoSelectSteel("AUTO1", 3, MyName, "ANGLE2")

   'get auto select list data
       ret = SapModel.PropFrame.GetAutoSelectSteel("AUTO1", NumberItems, SectName, AutoStartSection, Notes, GUID)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also