cPropFrameSDShapeGetReinfLine Method |
Retrieves property data for a line reinforcing shape in a section designer section
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetReinfLine(
string Name,
string ShapeName,
ref double X1,
ref double Y1,
ref double X2,
ref double Y2,
ref double Spacing,
ref string RebarSize,
ref bool EndBars,
ref string MatRebar
)
Function GetReinfLine (
Name As String,
ShapeName As String,
ByRef X1 As Double,
ByRef Y1 As Double,
ByRef X2 As Double,
ByRef Y2 As Double,
ByRef Spacing As Double,
ByRef RebarSize As String,
ByRef EndBars As Boolean,
ByRef MatRebar As String
) As Integer
int GetReinfLine(
String^ Name,
String^ ShapeName,
double% X1,
double% Y1,
double% X2,
double% Y2,
double% Spacing,
String^% RebarSize,
bool% EndBars,
String^% MatRebar
)
abstract GetReinfLine :
Name : string *
ShapeName : string *
X1 : float byref *
Y1 : float byref *
X2 : float byref *
Y2 : float byref *
Spacing : float byref *
RebarSize : string byref *
EndBars : bool byref *
MatRebar : string byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing frame section property that is a section designer section
- ShapeName
- Type: SystemString
The name of a line reinforcing shape in the section designer section
- X1
- Type: SystemDouble
The section designer X coordinate of the first drawn end point of the line reinforcing. [L]
- Y1
- Type: SystemDouble
The section designer Y coordinate of the first drawn end point of the line reinforcing. [L]
- X2
- Type: SystemDouble
The section designer X coordinate of the second drawn end point of the line reinforcing. [L]
- Y2
- Type: SystemDouble
The section designer Y coordinate of the second drawn end point of the line reinforcing. [L]
- Spacing
- Type: SystemDouble
The center-to-center spacing of the bars in the line pattern shape. [L]
- RebarSize
- Type: SystemString
The size of the reinforcing bars used in the line reinforcing shape
- EndBars
- Type: SystemBoolean
This item is True when there are bars at the end points of the line reinforcing
- MatRebar
- Type: SystemString
The material property for the reinforcing steel
Return Value
Type:
Int32
Returns zero if the property data is successfully retrieved; otherwise it returns a nonzero value
Remarks
See Also