cFrameObjSetGroupAssign Method

Adds or removes frame objects from a specified group.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int SetGroupAssign(
	string Name,
	string GroupName,
	bool Remove = false,
	eItemType ItemType = eItemType.Objects
)

Parameters

Name
Type: SystemString
The name of an existing point object or group depending on the value of the ItemType item.
GroupName
Type: SystemString
The name of an existing group to which the assignment is made.
Remove (Optional)
Type: SystemBoolean
ItemType (Optional)
Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
  • Object = 0
  • Group = 1
  • SelectedObjects = 2

If this item is Objects, the frame object specified by the Name item is added or removed from the group specified by the GroupName item.

If this item is Group, all frame objects in the group specified by the Name item are added or removed from the group specified by the GroupName item.

If this item is SelectedObjects, all selected frame objects are added or removed from the group specified by the GroupName item and the Name item is ignored.

Return Value

Type: Int32
Returns zero if the group assignment is successful, otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
   Dim SapModel As cSapModel
   Dim EtabsObject As cOAPI
   Dim ret As Integer = -1

'create ETABS object
   EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

'start ETABS application
  ret = EtabsObject.ApplicationStart()

'create SapModel object
   SapModel = EtabsObject.SapModel

'initialize model
   ret = SapModel.InitializeNewModel()

'create steel deck template model
   ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)

'define new group
   ret = SapModel.GroupDef.SetGroup("Group1")

'add frame objects to group
   ret = SapModel.FrameObj.SetGroupAssign("8", "Group1")
   ret = SapModel.FrameObj.SetGroupAssign("10", "Group1")

'select objects in group
   ret = SapModel.SelectObj.Group("Group1")

'close ETABS
   EtabsObject.ApplicationExit(False)

'clean up variables
   SapModel = Nothing
   EtabsObject = Nothing

End Sub
See Also