cAnalyzeModifyUndeformedGeometryModeShape Method

Modifies the undeformed geometry based on the shape of a specified mode

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int ModifyUndeformedGeometryModeShape(
	string CaseName,
	int Mode,
	double MaxDispl,
	int Direction,
	bool Original = false
)

Parameters

CaseName
Type: SystemString
Mode
Type: SystemInt32
The mode shape
MaxDispl
Type: SystemDouble
The maximum displacement to which the mode shape will be scaled
Direction
Type: SystemInt32
The direction in which to apply the geometry modification
  1. X
  2. Y
  3. Z
  4. Resultant
Original (Optional)
Type: SystemBoolean
If this item is True, all other input items in this function are ignored and the original undeformed geometry data is reinstated.

Return Value

Type: Int32
Returns zero if it is successful; otherwise it returns a nonzero value
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'assign point object restraints
       ReDim Value(5)
       For i = 0 To 5
           Value(i) = True
       Next i
       ret = SapModel.PointObj.SetRestraint("1", Value)

   'run analysis
       System.IO.Directory.CreateDirectory("c:\CSI_API_temp")
       ret = SapModel.File.Save("C:\CSI_API_temp\example.edb")
       ret = SapModel.Analyze.RunAnalysis

   'modify undeformed geometry
       ret = SapModel.Analyze.ModifyUndeformedGeometryModeShape("Modal", 1, 1.0, 2) 

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also