cAnalyze Interface

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
public interface cAnalyze

The cAnalyze type exposes the following members.

Methods
  NameDescription
Public methodCreateAnalysisModel
Creates the analysis model. If the analysis model is already created and current, nothing is done.
Public methodDeleteResults
Deletes results for load cases.
Public methodGetActiveDOF
Retrieves the model global degrees of freedom.
Public methodGetCaseStatus
Retrieves the status for all load cases.
Public methodGetRunCaseFlag
Retrieves the run flags for all analysis cases.
Public methodGetSolverOption
Public methodGetSolverOption_1
Retrieves the model solver options.
Public methodModifyUndeformedGeometry
Modifies the undeformed geometry based on displacements obtained from a specified load case
Public methodModifyUndeformedGeometryModeShape
Modifies the undeformed geometry based on the shape of a specified mode
Public methodRunAnalysis
Runs the analysis.
Public methodSetActiveDOF
Sets the model global degrees of freedom.
Public methodSetRunCaseFlag
Sets the run flag for load cases.
Public methodSetSolverOption
Public methodSetSolverOption_1
Sets the model solver options.
Top
See Also