cFrameObjGetLocalAxes Method |
Retrieves the frame local axis angle assignment for frame objects.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetLocalAxes(
string Name,
ref double Ang,
ref bool Advanced
)
Function GetLocalAxes (
Name As String,
ByRef Ang As Double,
ByRef Advanced As Boolean
) As Integer
int GetLocalAxes(
String^ Name,
double% Ang,
bool% Advanced
)
abstract GetLocalAxes :
Name : string *
Ang : float byref *
Advanced : bool byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing frame object.
- Ang
- Type: SystemDouble
This is the angle that the local 2 and 3 axes are rotated about the
positive local 1 axis, from the default orientation or,
if the Advanced item is True, from the orientation determined by
the plane reference vector. The rotation for a positive angle appears
counter clockwise when the local +1 axis is pointing toward you. [deg]
- Advanced
- Type: SystemBoolean
This item is True if the line object local axes orientation was
obtained using advanced local axes parameters.
Return Value
Type:
Int32
Returns zero if the assignment is successfully retrieved,
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.FrameObj.GetLocalAxes("3", Ang, Advanced)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also