cFrameObjSetEndLengthOffset Method |
Assigns frame object end offsets along the 1-axis of the object.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetEndLengthOffset(
string Name,
bool AutoOffset,
double Length1,
double Length2,
double RZ,
eItemType ItemType = eItemType.Objects
)
Function SetEndLengthOffset (
Name As String,
AutoOffset As Boolean,
Length1 As Double,
Length2 As Double,
RZ As Double,
Optional ItemType As eItemType = eItemType.Objects
) As Integer
int SetEndLengthOffset(
String^ Name,
bool AutoOffset,
double Length1,
double Length2,
double RZ,
eItemType ItemType = eItemType::Objects
)
abstract SetEndLengthOffset :
Name : string *
AutoOffset : bool *
Length1 : float *
Length2 : float *
RZ : float *
?ItemType : eItemType
(* Defaults:
let _ItemType = defaultArg ItemType eItemType.Objects
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing frame object or group, depending on the
value of the ItemType item.
- AutoOffset
- Type: SystemBoolean
If this item is True, the end length offsets are automatically
determined by the program from object connectivity, and the
length1, length2 and
rz items are ignored.
- Length1
- Type: SystemDouble
- Length2
- Type: SystemDouble
- RZ
- Type: SystemDouble
The rigid zone factor. This is the fraction of the end offset length
assumed to be rigid for bending and shear deformations.
- ItemType (Optional)
- Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the assignment is made to the frame object
specified by the Name item.
If this item is Group, the assignment is made to all frame objects
in the group specified by the Name item.
If this item is SelectedObjects, the assignment is made to all
selected frame objects and the Name item is ignored.
Return Value
Type:
Int32
Returns zero if the offsets are successfully assigned,
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.FrameObj.SetEndLengthOffset("15", False, 12, 12, 0.5)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also