cPropFrameSDShapeGetConcreteL Method

Retrieves property data for a concrete L shape in a section designer section

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetConcreteL(
	string Name,
	string ShapeName,
	ref string MatProp,
	ref string PropName,
	ref int Color,
	ref double XCenter,
	ref double YCenter,
	ref double H,
	ref double Bf,
	ref double Tf,
	ref double Tw,
	ref double Rotation,
	ref bool MirrorAbout2,
	ref bool MirrorAbout3
)

Parameters

Name
Type: SystemString
The name of an existing frame section property that is a section designer section
ShapeName
Type: SystemString
The name of an existing concrete L shape in the specified frame section property
MatProp
Type: SystemString
The name of the material property for the shape
PropName
Type: SystemString
This is a blank string or the name of a defined concrete L property that has been imported from a section property file. If it is the name of a defined concrete L property, the section dimensions are taken from that property
Color
Type: SystemInt32
The fill color assigned to the shape
XCenter
Type: SystemDouble
The X-coordinate of the center of the shape in the section designer coordinate system. [L]
YCenter
Type: SystemDouble
The Y-coordinate of the center of the shape in the section designer coordinate system. [L]
H
Type: SystemDouble
The section depth. [L]
Bf
Type: SystemDouble
The flange width. [L]
Tf
Type: SystemDouble
The flange thickness. [L]
Tw
Type: SystemDouble
The web thickness. [L]
Rotation
Type: SystemDouble
The counter clockwise rotation of the shape from its default orientation. [deg]
MirrorAbout2
Type: SystemBoolean
Indicates whether the section is mirrored about the local 2-axis.
MirrorAbout3
Type: SystemBoolean
Indicates whether the section is mirrored about the local 3-axis.

Return Value

Type: Int32
Returns zero if the property data is successfully retrieved; otherwise it returns a nonzero value
Remarks