cAnalysisResultsJointReact Method |
Reports the joint reactions for the specified point elements. The reactions reported are from
restraints, springs and grounded (one-joint) links.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint JointReact(
string Name,
eItemTypeElm ItemTypeElm,
ref int NumberResults,
ref string[] Obj,
ref string[] Elm,
ref string[] LoadCase,
ref string[] StepType,
ref double[] StepNum,
ref double[] F1,
ref double[] F2,
ref double[] F3,
ref double[] M1,
ref double[] M2,
ref double[] M3
)
Function JointReact (
Name As String,
ItemTypeElm As eItemTypeElm,
ByRef NumberResults As Integer,
ByRef Obj As String(),
ByRef Elm As String(),
ByRef LoadCase As String(),
ByRef StepType As String(),
ByRef StepNum As Double(),
ByRef F1 As Double(),
ByRef F2 As Double(),
ByRef F3 As Double(),
ByRef M1 As Double(),
ByRef M2 As Double(),
ByRef M3 As Double()
) As Integer
int JointReact(
String^ Name,
eItemTypeElm ItemTypeElm,
int% NumberResults,
array<String^>^% Obj,
array<String^>^% Elm,
array<String^>^% LoadCase,
array<String^>^% StepType,
array<double>^% StepNum,
array<double>^% F1,
array<double>^% F2,
array<double>^% F3,
array<double>^% M1,
array<double>^% M2,
array<double>^% M3
)
abstract JointReact :
Name : string *
ItemTypeElm : eItemTypeElm *
NumberResults : int byref *
Obj : string[] byref *
Elm : string[] byref *
LoadCase : string[] byref *
StepType : string[] byref *
StepNum : float[] byref *
F1 : float[] byref *
F2 : float[] byref *
F3 : float[] byref *
M1 : float[] byref *
M2 : float[] byref *
M3 : float[] byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing point object, point element, or group of objects
depending on the value of the ItemTypeElm item. - ItemTypeElm
- Type: ETABS2016eItemTypeElm
This is one of the following items in the eItemTypeElm
enumeration.
If this item is ObjectElm, the result request is for the point
element corresponding to the point object specified by the Name item.
If this item is Element, the result request is for the point
element specified by the Name item.
If this item is GroupElm, the result request is for all point
elements directly or indirectly specified in the group specified by the
Name item.
If this item is SelectionElm, the result request is for all point
elements directly or indirectly selected and the Name item is ignored.
- NumberResults
- Type: SystemInt32
The total number of results returned by the program. - Obj
- Type: SystemString
- Elm
- Type: SystemString
- LoadCase
- Type: SystemString
This is an array that includes the name of the analysis case or load
combination associated with each result. - StepType
- Type: SystemString
This is an array that includes the step type, if any, for each result. - StepNum
- Type: SystemDouble
This is an array that includes the step number, if any, for each result. - F1
- Type: SystemDouble
This is a one dimensional array that includes the reaction forces in the point element local 1 axis direction. [F]. - F2
- Type: SystemDouble
This is a one dimensional array that includes the reaction forces in the point element local 2 axis direction. [F]. - F3
- Type: SystemDouble
This is a one dimensional array that includes the reaction forces in the point element local 3 axis direction. [F]. - M1
- Type: SystemDouble
This is a one dimensional array that includes the reaction moments about the point element local 1 axis direction. [FL]. - M2
- Type: SystemDouble
This is a one dimensional array that includes the reaction moments about the point element local 2 axis direction. [FL]. - M3
- Type: SystemDouble
This is a one dimensional array that includes the reaction moments about the point element local 3 axis direction. [FL].
Return Value
Type:
Int32Returns zero if the reactions are successfully recovered;
otherwise it returns a nonzero value.
RemarksSee
Results for more information.
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim NumberResults As Integer
Dim Obj() As String
Dim Elm() As String
Dim LoadCase() As String
Dim StepType() As String
Dim StepNum() As Double
Dim F1() As Double
Dim F2() As Double
Dim F3() As Double
Dim M1() As Double
Dim M2() As Double
Dim M3() As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
System.IO.Directory.CreateDirectory("c:\CSI_API_temp")
ret = SapModel.File.Save("C:\CSI_API_temp\example.edb")
ret = SapModel.Analyze.RunAnalysis()
ret = SapModel.Results.Setup.DeselectAllCasesAndCombosForOutput()
ret = SapModel.Results.Setup.SetCaseSelectedForOutput("DEAD")
ret = SapModel.Results.JointReact("1", eItemTypeElm.Element, NumberResults, Obj, Elm, LoadCase, StepType, StepNum, F1, F2, F3, M1, M2, M3)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also