cPointObjGetLocalAxes Method |
Retrieves the local axis angles for a point object.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetLocalAxes(
string Name,
ref double A,
ref double B,
ref double C,
ref bool Advanced
)
Function GetLocalAxes (
Name As String,
ByRef A As Double,
ByRef B As Double,
ByRef C As Double,
ByRef Advanced As Boolean
) As Integer
int GetLocalAxes(
String^ Name,
double% A,
double% B,
double% C,
bool% Advanced
)
abstract GetLocalAxes :
Name : string *
A : float byref *
B : float byref *
C : float byref *
Advanced : bool byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing point object.
- A
- Type: SystemDouble
- B
- Type: SystemDouble
The local axes of the point are defined by first setting the
positive local 1, 2 and 3 axes the same as the positive global X, Y and Z axes
and then doing the following: [deg]
- Rotate about the 3 axis by angle a.
- Rotate about the resulting 2 axis by angle b.DOF must be active.
- Rotate about the resulting 1 axis by angle c.DOF must not be fixed.
- C
- Type: SystemDouble
- Advanced
- Type: SystemBoolean
This item is True if the point object local axes orientation was obtained
using advanced local axes parameters.
Return Value
Type:
Int32Returns zero if the local axes angles are successfully retrieved,
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim GUID As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.PointObj.GetLocalAxes("1", a, b, c, Advanced)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also