cPointObjDeleteSpecialPoint Method

Deletes special point objects that have no other objects connected to them.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int DeleteSpecialPoint(
	string Name,
	eItemType ItemType = eItemType.Objects
)

Parameters

Name
Type: SystemString
The name of an existing point object or group depending on the value of the ItemType item.
ItemType (Optional)
Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
  • Object = 0
  • Group = 1
  • SelectedObjects = 2

If Objects is selected, the deletion applies to the point object specified by the Name item.

If Group is selected, the deletion applies to all point objects in the group specified by the Name item.

If SelectedObjects is selected, the deletion applies to all selected point objects, and the Name item is ignored.

Return Value

Type: Int32
Returns zero if the function completes successfully, otherwise it returns a nonzero value.
Remarks
Point objects can be deleted only if they have no other objects (e.g., frame, cable, tendon, area, solid link) connected to them. If a point object is not specified to be a Special Point, the program automatically deletes that point object when it has no other objects connected to it. If a point object is specified to be a Special Point, to delete it, first delete all other objects connected to the point and then call this function to delete the point.
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)

   'set as special point
       ret = SapModel.PointObj.SetSpecialPoint("3", True)

   'delete frame objects
       ret = SapModel.FrameObj.Delete("2")
       ret = SapModel.FrameObj.Delete("8")

   'delete special point object
       ret = SapModel.PointObj.DeleteSpecialPoint("3")

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also