cAnalysisResultsAreaStressShellLayered Method |
Reports the area stresses for the specified area elements that are assigned layered shell section properties
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint AreaStressShellLayered(
string Name,
eItemTypeElm ItemTypeElm,
ref int NumberResults,
ref string[] Obj,
ref string[] Elm,
ref string[] Layer,
ref int[] IntPtNum,
ref double[] IntPtLoc,
ref string[] PointElm,
ref string[] LoadCase,
ref string[] StepType,
ref double[] StepNum,
ref double[] S11,
ref double[] S22,
ref double[] S12,
ref double[] SMax,
ref double[] SMin,
ref double[] SAngle,
ref double[] SVM,
ref double[] S13Avg,
ref double[] S23Avg,
ref double[] SMaxAvg,
ref double[] SAngleAvg
)
Function AreaStressShellLayered (
Name As String,
ItemTypeElm As eItemTypeElm,
ByRef NumberResults As Integer,
ByRef Obj As String(),
ByRef Elm As String(),
ByRef Layer As String(),
ByRef IntPtNum As Integer(),
ByRef IntPtLoc As Double(),
ByRef PointElm As String(),
ByRef LoadCase As String(),
ByRef StepType As String(),
ByRef StepNum As Double(),
ByRef S11 As Double(),
ByRef S22 As Double(),
ByRef S12 As Double(),
ByRef SMax As Double(),
ByRef SMin As Double(),
ByRef SAngle As Double(),
ByRef SVM As Double(),
ByRef S13Avg As Double(),
ByRef S23Avg As Double(),
ByRef SMaxAvg As Double(),
ByRef SAngleAvg As Double()
) As Integer
int AreaStressShellLayered(
String^ Name,
eItemTypeElm ItemTypeElm,
int% NumberResults,
array<String^>^% Obj,
array<String^>^% Elm,
array<String^>^% Layer,
array<int>^% IntPtNum,
array<double>^% IntPtLoc,
array<String^>^% PointElm,
array<String^>^% LoadCase,
array<String^>^% StepType,
array<double>^% StepNum,
array<double>^% S11,
array<double>^% S22,
array<double>^% S12,
array<double>^% SMax,
array<double>^% SMin,
array<double>^% SAngle,
array<double>^% SVM,
array<double>^% S13Avg,
array<double>^% S23Avg,
array<double>^% SMaxAvg,
array<double>^% SAngleAvg
)
abstract AreaStressShellLayered :
Name : string *
ItemTypeElm : eItemTypeElm *
NumberResults : int byref *
Obj : string[] byref *
Elm : string[] byref *
Layer : string[] byref *
IntPtNum : int[] byref *
IntPtLoc : float[] byref *
PointElm : string[] byref *
LoadCase : string[] byref *
StepType : string[] byref *
StepNum : float[] byref *
S11 : float[] byref *
S22 : float[] byref *
S12 : float[] byref *
SMax : float[] byref *
SMin : float[] byref *
SAngle : float[] byref *
SVM : float[] byref *
S13Avg : float[] byref *
S23Avg : float[] byref *
SMaxAvg : float[] byref *
SAngleAvg : float[] byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing area object, area element or group of objects,
depending on the value of the ItemTypeElm item
- ItemTypeElm
- Type: ETABS2016eItemTypeElm
This is one of the following items in the eItemTypeElm
enumeration.
If this item is ObjectElm, the result request is for the area elements
corresponding to the area object specified by the Name item.
If this item is Element, the result request is for the area
element specified by the Name item.
If this item is GroupElm, the result request is for the area elements
corresponding to all area objects included in the group specified by the Name item.
If this item is SelectionElm, the result request is for area elements
corresponding to all selected area objects and the Name item is ignored.
- NumberResults
- Type: SystemInt32
The total number of results returned by the program
- Obj
- Type: SystemString
This is an array that includes the area object name associated with each result, if any
- Elm
- Type: SystemString
This is an array that includes the area element name associated with each result
- Layer
- Type: SystemString
This is an array that includes the layer name associated with each result
- IntPtNum
- Type: SystemInt32
This is an array that includes the integration point number within the specified layer of the area element
- IntPtLoc
- Type: SystemDouble
This is an array that includes the integration point relative location within the specified layer of the area element.
The location is between -1 (bottom of layer) and +1 (top of layer), inclusive.
The midheight of the layer is at a value of 0
- PointElm
- Type: SystemString
This is an array that includes the name of the point element where the results are reported
- LoadCase
- Type: SystemString
This is an array that includes the name of the analysis case or load combination associated with each result
- StepType
- Type: SystemString
This is an array that includes the step type, if any, for each result
- StepNum
- Type: SystemDouble
This is an array that includes the step number, if any, for each result
- S11
- Type: SystemDouble
The area element internal S11 stress at the specified point element location,
for the specified layer and layer integration point, reported in the area element local coordinate system. [F/L2]
- S22
- Type: SystemDouble
The area element internal S22 stress at the specified point element location,
for the specified layer and layer integration point, reported in the area element local coordinate system. [F/L2]
- S12
- Type: SystemDouble
The area element internal S12 stress at the specified point element location,
for the specified layer and layer integration point, reported in the area element local coordinate system. [F/L2]
- SMax
- Type: SystemDouble
The area element maximum principal stress at the specified point element location,
for the specified layer and layer integration point. [F/L2]
- SMin
- Type: SystemDouble
The area element minimum principal stress at the specified point element location,
for the specified layer and layer integration point. [F/L2]
- SAngle
- Type: SystemDouble
The angle measured counter clockwise (when the local 3 axis is pointing toward you)
from the area local 1 axis to the direction of the maximum principal stress. [deg]
- SVM
- Type: SystemDouble
The area element internal Von Mises stress at the specified point element location,
for the specified layer and layer integration point. [F/L2]
- S13Avg
- Type: SystemDouble
The area element average S13 out-of-plane shear stress at the specified point element location,
for the specified layer and layer integration point. [F/L2]
- S23Avg
- Type: SystemDouble
The area element average S23 out-of-plane shear stress at the specified point element location,
for the specified layer and layer integration point. [F/L2]
- SMaxAvg
- Type: SystemDouble
The area element maximum average out-of-plane shear stress for the specified layer and layer integration point.
It is equal to the square root of the sum of the squares of S13Avg and S23Avg. [F/L2]
- SAngleAvg
- Type: SystemDouble
The angle measured counter clockwise (when the local 3 axis is pointing toward you)
from the area local 1 axis to the direction of SMaxAvg. [deg]
Return Value
Type:
Int32
Returns zero if the stresses are successfully recovered, otherwise it returns a nonzero value
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim NumberResults As Integer
Dim Obj() As String
Dim ObjSta() As Double
Dim Elm() As String
Dim ElmSta() As Double
Dim LoadCase() As String
Dim StepType() As String
Dim StepNum() As Double
Dim S11Top() As Double
Dim S22Top() As Double
Dim S12Top() As Double
Dim SMaxTop() As Double
Dim SMinTop() As Double
Dim SAngleTop() As Double
Dim SVMTop() As Double
Dim S11Bot() As Double
Dim S22Bot() As Double
Dim S12Bot() As Double
Dim SMaxBot() As Double
Dim SMinBot() As Double
Dim SAngleBot() As Double
Dim SVMBot() As Double
Dim S13Avg() As Double
Dim S23Avg() As Double
Dim SMaxAvg() As Double
Dim SAngleAvg() As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
System.IO.Directory.CreateDirectory("c:\CSI_API_temp")
ret = SapModel.File.Save("C:\CSI_API_temp\example.edb")
ret = SapModel.Analyze.RunAnalysis()
ret = SapModel.Results.Setup.DeselectAllCasesAndCombosForOutput()
ret = SapModel.Results.Setup.SetCaseSelectedForOutput("DEAD")
ret = SapModel.Results.AreaStressShellLayered("1", eItemTypeElm.ObjectElm, NumberResults, Obj, Elm, Layer, IntPtNum, IntPtLoc, PointElm, LoadCase, StepType, StepNum, S11, S22, S12, SMax, SMin, SAngle, SVM, S13Avg, S23Avg, SMaxAvg, SAngleAvg)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also