cPointObjGetLoadForce Method |
Retrieves the joint force load assignments to point objects.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetLoadForce(
string Name,
ref int NumberItems,
ref string[] PointName,
ref string[] LoadPat,
ref int[] LcStep,
ref string[] CSys,
ref double[] F1,
ref double[] F2,
ref double[] F3,
ref double[] M1,
ref double[] M2,
ref double[] M3,
eItemType ItemType = eItemType.Objects
)
Function GetLoadForce (
Name As String,
ByRef NumberItems As Integer,
ByRef PointName As String(),
ByRef LoadPat As String(),
ByRef LcStep As Integer(),
ByRef CSys As String(),
ByRef F1 As Double(),
ByRef F2 As Double(),
ByRef F3 As Double(),
ByRef M1 As Double(),
ByRef M2 As Double(),
ByRef M3 As Double(),
Optional ItemType As eItemType = eItemType.Objects
) As Integer
int GetLoadForce(
String^ Name,
int% NumberItems,
array<String^>^% PointName,
array<String^>^% LoadPat,
array<int>^% LcStep,
array<String^>^% CSys,
array<double>^% F1,
array<double>^% F2,
array<double>^% F3,
array<double>^% M1,
array<double>^% M2,
array<double>^% M3,
eItemType ItemType = eItemType::Objects
)
abstract GetLoadForce :
Name : string *
NumberItems : int byref *
PointName : string[] byref *
LoadPat : string[] byref *
LcStep : int[] byref *
CSys : string[] byref *
F1 : float[] byref *
F2 : float[] byref *
F3 : float[] byref *
M1 : float[] byref *
M2 : float[] byref *
M3 : float[] byref *
?ItemType : eItemType
(* Defaults:
let _ItemType = defaultArg ItemType eItemType.Objects
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing point object or group depending on the
value of the ItemType item.
- NumberItems
- Type: SystemInt32
This is the total number of joint force load assignments returned.
- PointName
- Type: SystemString
This is an array that includes the name of the point object to which
the specified joint force load assignment applies.
- LoadPat
- Type: SystemString
This is an array that includes the name of the load pattern for
the joint force load.
- LcStep
- Type: SystemInt32
- CSys
- Type: SystemString
This is an array that includes the name of the coordinate system
for the joint force load. This is Local or
the name of a defined coordinate system.
- F1
- Type: SystemDouble
This is an array that includes the assigned translational force
in the local 1-axis or coordinate system X-axis direction,
depending on the specified CSys. [L]
- F2
- Type: SystemDouble
This is an array that includes the assigned translational force
in the local 2-axis or coordinate system Y-axis direction,
depending on the specified CSys. [L]
- F3
- Type: SystemDouble
This is an array that includes the assigned translational force
in the local 3-axis or coordinate system Z-axis direction,
depending on the specified CSys. [L]
- M1
- Type: SystemDouble
This is an array that includes the assigned moment
about the local 1-axis or coordinate system X-axis,
depending on the specified CSys. [rad]
- M2
- Type: SystemDouble
This is an array that includes the assigned moment
about the local 2-axis or coordinate system Y-axis,
depending on the specified CSys. [rad]
- M3
- Type: SystemDouble
This is an array that includes the assigned moment
about the local 3-axis or coordinate system Z-axis,
depending on the specified CSys. [rad]
- ItemType (Optional)
- Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the load assignments are retrieved for the point object
specified by the Name item.
If this item is Group, the load assignments are retrieved for all point objects
in the group specified by the Name item.
If this item is SelectedObjects, the load assignments are retrieved for all
selected point objects and the Name item is ignored.
Return Value
Type:
Int32
Returns zero if the load assignments are successfully retrieved,
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim NumberItems As Long
Dim PointName() As String
Dim LoadPat() As String
Dim LCStep() As Long
Dim CSys() As String
Dim F1() As Double
Dim F2() As Double
Dim F3() As Double
Dim M1() As Double
Dim M2() As Double
Dim M3() As Double
Dim Value() As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
Redim Value(5)
Value(0) = 10
ret = SapModel.PointObj.SetLoadForce("1", "DEAD", Value)
ret = SapModel.PointObj.GetLoadForce("ALL", NumberItems, PointName, LoadPat, LCStep, CSys, F1, F2, F3, M1, M2, M3, eItemType.Group)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also