cAnalysisResultsAreaForceShell Method |
Reports the area forces for the specified area elements that are assigned
shell section properties (not plane or asolid properties).
Note that the forces reported are per unit of in-plane length.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint AreaForceShell(
string Name,
eItemTypeElm ItemTypeElm,
ref int NumberResults,
ref string[] Obj,
ref string[] Elm,
ref string[] PointElm,
ref string[] LoadCase,
ref string[] StepType,
ref double[] StepNum,
ref double[] F11,
ref double[] F22,
ref double[] F12,
ref double[] FMax,
ref double[] FMin,
ref double[] FAngle,
ref double[] FVM,
ref double[] M11,
ref double[] M22,
ref double[] M12,
ref double[] MMax,
ref double[] MMin,
ref double[] MAngle,
ref double[] V13,
ref double[] V23,
ref double[] VMax,
ref double[] VAngle
)
Function AreaForceShell (
Name As String,
ItemTypeElm As eItemTypeElm,
ByRef NumberResults As Integer,
ByRef Obj As String(),
ByRef Elm As String(),
ByRef PointElm As String(),
ByRef LoadCase As String(),
ByRef StepType As String(),
ByRef StepNum As Double(),
ByRef F11 As Double(),
ByRef F22 As Double(),
ByRef F12 As Double(),
ByRef FMax As Double(),
ByRef FMin As Double(),
ByRef FAngle As Double(),
ByRef FVM As Double(),
ByRef M11 As Double(),
ByRef M22 As Double(),
ByRef M12 As Double(),
ByRef MMax As Double(),
ByRef MMin As Double(),
ByRef MAngle As Double(),
ByRef V13 As Double(),
ByRef V23 As Double(),
ByRef VMax As Double(),
ByRef VAngle As Double()
) As Integer
int AreaForceShell(
String^ Name,
eItemTypeElm ItemTypeElm,
int% NumberResults,
array<String^>^% Obj,
array<String^>^% Elm,
array<String^>^% PointElm,
array<String^>^% LoadCase,
array<String^>^% StepType,
array<double>^% StepNum,
array<double>^% F11,
array<double>^% F22,
array<double>^% F12,
array<double>^% FMax,
array<double>^% FMin,
array<double>^% FAngle,
array<double>^% FVM,
array<double>^% M11,
array<double>^% M22,
array<double>^% M12,
array<double>^% MMax,
array<double>^% MMin,
array<double>^% MAngle,
array<double>^% V13,
array<double>^% V23,
array<double>^% VMax,
array<double>^% VAngle
)
abstract AreaForceShell :
Name : string *
ItemTypeElm : eItemTypeElm *
NumberResults : int byref *
Obj : string[] byref *
Elm : string[] byref *
PointElm : string[] byref *
LoadCase : string[] byref *
StepType : string[] byref *
StepNum : float[] byref *
F11 : float[] byref *
F22 : float[] byref *
F12 : float[] byref *
FMax : float[] byref *
FMin : float[] byref *
FAngle : float[] byref *
FVM : float[] byref *
M11 : float[] byref *
M22 : float[] byref *
M12 : float[] byref *
MMax : float[] byref *
MMin : float[] byref *
MAngle : float[] byref *
V13 : float[] byref *
V23 : float[] byref *
VMax : float[] byref *
VAngle : float[] byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing area object, area element or group of objects,
depending on the value of the ItemTypeElm item
- ItemTypeElm
- Type: ETABS2016eItemTypeElm
This is one of the following items in the eItemTypeElm
enumeration.
If this item is ObjectElm, the result request is for the area elements
corresponding to the area object specified by the Name item.
If this item is Element, the result request is for the area
element specified by the Name item.
If this item is GroupElm, the result request is for the area elements
corresponding to all area objects included in the group specified by the Name item.
If this item is SelectionElm, the result request is for area elements
corresponding to all selected area objects and the Name item is ignored.
- NumberResults
- Type: SystemInt32
The total number of results returned by the program
- Obj
- Type: SystemString
This is an array that includes the area object name associated with each result, if any
- Elm
- Type: SystemString
This is an array that includes the area element name associated with each result
- PointElm
- Type: SystemString
This is an array that includes the name of the point element where the results are reported
- LoadCase
- Type: SystemString
This is an array that includes the name of the analysis case or load combination associated with each result
- StepType
- Type: SystemString
This is an array that includes the step type, if any, for each result
- StepNum
- Type: SystemDouble
This is an array that includes the step number, if any, for each result
- F11
- Type: SystemDouble
The area element internal F11 membrane direct force per length reported
in the area element local coordinate system. [F/L]
- F22
- Type: SystemDouble
The area element internal F22 membrane direct force per length reported
in the area element local coordinate system. [F/L]
- F12
- Type: SystemDouble
The area element internal F12 membrane shear force per length reported
in the area element local coordinate system. [F/L]
- FMax
- Type: SystemDouble
The maximum principal membrane force per length. [F/L]
- FMin
- Type: SystemDouble
The minimum principal membrane force per length. [F/L]
- FAngle
- Type: SystemDouble
The angle measured counter clockwise (when the local 3 axis is pointing toward you)
from the area local 1 axis to the direction of the maximum principal membrane force. [deg]
- FVM
- Type: SystemDouble
The area element internal Von Mises membrane force per length. [F/L]
- M11
- Type: SystemDouble
The area element internal M11 plate bending moment per length reported in the area element local coordinate system.
This item is only reported for area elements with properties that allow plate bending behavior. [FL/L]
- M22
- Type: SystemDouble
The area element internal M22 plate bending moment per length reported in the area element local coordinate system.
This item is only reported for area elements with properties that allow plate bending behavior. [FL/L]
- M12
- Type: SystemDouble
The area element internal M12 plate twisting moment per length reported in the area element local coordinate system.
This item is only reported for area elements with properties that allow plate bending behavior. [FL/L]
- MMax
- Type: SystemDouble
The maximum principal plate moment per length.
This item is only reported for area elements with properties that allow plate bending behavior. [FL/L]
- MMin
- Type: SystemDouble
The minimum principal plate moment per length.
This item is only reported for area elements with properties that allow plate bending behavior. [FL/L]
- MAngle
- Type: SystemDouble
The angle measured counter clockwise (when the local 3 axis is pointing toward you) from the area local 1 axis to the direction of the maximum principal plate moment.
This item is only reported for area elements with properties that allow plate bending behavior. [deg]
- V13
- Type: SystemDouble
The area element internal V13 plate transverse shear force per length reported in the area element local coordinate system.
This item is only reported for area elements with properties that allow plate bending behavior. [F/L]
- V23
- Type: SystemDouble
The area element internal V23 plate transverse shear force per length reported in the area element local coordinate system.
This item is only reported for area elements with properties that allow plate bending behavior. [F/L]
- VMax
- Type: SystemDouble
The maximum plate transverse shear force. It is equal to the square root of the sum of the squares of V13 and V23.
This item is only reported for area elements with properties that allow plate bending behavior. [F/L]
- VAngle
- Type: SystemDouble
The angle measured counter clockwise (when the local 3 axis is pointing toward you) from the area local 1 axis to the direction of Vmax.
This item is only reported for area elements with properties that allow plate bending behavior. [deg]
Return Value
Type:
Int32
Returns zero if the forces are successfully recovered, otherwise it returns a nonzero value
Remarks
ExamplesPublic Sub Example()
Dim SapObject as cOAPI
Dim SapModel As cSapModel
Dim ret As Long
Dim NumberResults As Long
Dim Obj() As String
Dim Elm() As String
Dim PointElm() As String
Dim LoadCase() As String
Dim StepType() As String
Dim StepNum() As Double
Dim F11() As Double
Dim F22() As Double
Dim F12() As Double
Dim FMax() As Double
Dim FMin() As Double
Dim FAngle() As Double
Dim FVM() As Double
Dim M11() As Double
Dim M22() As Double
Dim M12() As Double
Dim MMax() As Double
Dim MMin() As Double
Dim MAngle() As Double
Dim V13() As Double
Dim V23() As Double
Dim VMax() As Double
Dim VAngle() As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
System.IO.Directory.CreateDirectory("c:\CSI_API_temp")
ret = SapModel.File.Save("C:\CSI_API_temp\example.edb")
ret = SapModel.Analyze.RunAnalysis()
ret = SapModel.Results.Setup.DeselectAllCasesAndCombosForOutput()
ret = SapModel.Results.Setup.SetCaseSelectedForOutput("DEAD")
ret = SapModel.Results.AreaForceShell("1", eItemTypeElm.ObjectElm, NumberResults, Obj, Elm, PointElm, LoadCase, StepType, StepNum, F11, F22, F12, FMax, FMin, FAngle, FVM, M11, M22, M12, MMax, MMin, MAngle, V13, V23, VMax, VAngle)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also