cPropAreaGetShellDesign Method |
Retrieves area property design parameters for a shell-type area section.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetShellDesign(
string Name,
ref string MatProp,
ref int SteelLayoutOption,
ref double DesignCoverTopDir1,
ref double DesignCoverTopDir2,
ref double DesignCoverBotDir1,
ref double DesignCoverBotDir2
)
Function GetShellDesign (
Name As String,
ByRef MatProp As String,
ByRef SteelLayoutOption As Integer,
ByRef DesignCoverTopDir1 As Double,
ByRef DesignCoverTopDir2 As Double,
ByRef DesignCoverBotDir1 As Double,
ByRef DesignCoverBotDir2 As Double
) As Integer
int GetShellDesign(
String^ Name,
String^% MatProp,
int% SteelLayoutOption,
double% DesignCoverTopDir1,
double% DesignCoverTopDir2,
double% DesignCoverBotDir1,
double% DesignCoverBotDir2
)
abstract GetShellDesign :
Name : string *
MatProp : string byref *
SteelLayoutOption : int byref *
DesignCoverTopDir1 : float byref *
DesignCoverTopDir2 : float byref *
DesignCoverBotDir1 : float byref *
DesignCoverBotDir2 : float byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing shell-type area property. - MatProp
- Type: SystemString
The name of the material property for the area property. - SteelLayoutOption
- Type: SystemInt32
This is 0, 1 or 2 indicating, the rebar layout option.
Value | Layout |
---|
0 | Default |
1 | One layer |
2 | Two layers |
- DesignCoverTopDir1
- Type: SystemDouble
The cover to the centroid of the top reinforcing steel
running in the local 1 axis direction of the area object. [L]
This item applies only when SteelLayoutOption = 1 or 2.
- DesignCoverTopDir2
- Type: SystemDouble
The cover to the centroid of the top reinforcing
steel running in the local 2 axis direction of the area object. [L]
This item applies only when SteelLayoutOption = 1 or 2.
- DesignCoverBotDir1
- Type: SystemDouble
The cover to the centroid of the bottom reinforcing steel
running in the local 1 axis direction of the area object. [L]
This item applies only when SteelLayoutOption = 2.
- DesignCoverBotDir2
- Type: SystemDouble
The cover to the centroid of the bottom reinforcing steel
running in the local 2 axis direction of the area object. [L]
This item applies only when SteelLayoutOption = 2.
Return Value
Type:
Int32Returns zero if the parameters are successfully retrieved;
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim MatProp As String
Dim SteelLayoutOption As integer
Dim DesignCoverTopDir1 As Double
Dim DesignCoverTopDir2 As Double
Dim DesignCoverBotDir1 As Double
Dim DesignCoverBotDir2 As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropArea.GetShellDesign("SLAB1", MatProp, SteelLayoutOption, DesignCoverTopDir1, DesignCoverTopDir2, DesignCoverBotDir1, DesignCoverBotDir2)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also