cPropArea Interface

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
public interface cPropArea

The cPropArea type exposes the following members.

Methods
  NameDescription
Public methodChangeName
Changes the name of an existing area property.
Public methodCount
Returns the total number of defined area properties in the model. If desired, counts can be returned for all area properties of a specified type in the model.
Public methodDelete
Deletes a specified area property.
Public methodGetDeck
Retrieves property data for a deck section.
Public methodGetDeckFilled
Retrieves property data for a filled deck section.
Public methodGetDeckSolidSlab
Retrieves property data for a solid-slab deck section.
Public methodGetDeckUnfilled
Retrieves property data for an unfilled deck section.
Public methodGetModifiers
Retrieves the modifier assignments for an area property.
Public methodGetNameList
Retrieves the names of all defined area properties of the specified type.
Public methodGetShellDesign
Retrieves area property design parameters for a shell-type area section.
Public methodGetShellLayer
Retrieves area property layer parameters for a shell-type area section.
Public methodGetShellLayer_1
Retrieves area property layer parameters for a shell-type area section.
Public methodGetSlab
Retrieves property data for a slab section.
Public methodGetSlabRibbed
Retrieves property data for a ribbed slab section.
Public methodGetSlabWaffle
Retrieves property data for a waffle slab section.
Public methodGetTypeOAPI
Retrieves the property type for the specified area property.
Public methodGetWall
Retrieves property data for a wall section.
Public methodGetWallAutoSelectList
Retrieves property data for an auto select list wall section.
Public methodSetDeck
Initializes a deck property.
Public methodSetDeckFilled
Initializes a filled deck property
Public methodSetDeckSolidSlab
Initializes a solid-slab deck property
Public methodSetDeckUnfilled
Initializes an unfilled deck property
Public methodSetModifiers
Assigns property modifiers to an area property.
Public methodSetShellDesign
Assigns the design parameters for shell-type area properties.
Public methodSetShellLayer
Assigns the layer parameters for shell-type area properties
Public methodSetShellLayer_1
Assigns the layer parameters for shell-type area properties
Public methodSetSlab
Initializes a slab property.
Public methodSetSlabRibbed
Initializes a ribbed slab section.
Public methodSetSlabWaffle
Initializes a waffle slab section.
Public methodSetWall
Initializes property data for a wall section.
Public methodSetWallAutoSelectList
Initializes property data for an auto select list wall section.
Top
See Also