cPropFrameGetCircle Method

Retrieves frame section property data for a circular frame section.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetCircle(
	string Name,
	ref string FileName,
	ref string MatProp,
	ref double T3,
	ref int Color,
	ref string Notes,
	ref string GUID
)

Parameters

Name
Type: SystemString
The name of an existing circular frame section property.
FileName
Type: SystemString
If the section property was imported from a property file, this is the name of that file. If the section property was not imported, this item is blank.
MatProp
Type: SystemString
The name of the material property for the section.
T3
Type: SystemDouble
Color
Type: SystemInt32
Notes
Type: SystemString
GUID
Type: SystemString
The GUID (global unique identifier), if any, assigned to the section.

Return Value

Type: Int32
Returns zero if the section property data is successfully retrieved; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim Name As String
       Dim FileName As String
       Dim MatProp As String
       Dim t3 As Double
       Dim Color As Integer
       Dim Notes As String
       Dim GUID As String

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'set new frame section property
       ret = SapModel.PropFrame.SetCircle("C1", "4000Psi", 20)

   'get frame section property data
       ret = SapModel.PropFrame.GetCircle("C1", FileName, MatProp, t3, Color, Notes, GUID)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also