cPropAreaGetDeckUnfilled Method

Retrieves property data for an unfilled deck section.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetDeckUnfilled(
	string Name,
	ref double RibDepth,
	ref double RibWidthTop,
	ref double RibWidthBot,
	ref double RibSpacing,
	ref double ShearThickness,
	ref double UnitWeight
)

Parameters

Name
Type: SystemString
The name of an existing unfilled deck property.
RibDepth
Type: SystemDouble
Rib Depth, hr
RibWidthTop
Type: SystemDouble
Rib Width Top, wrt
RibWidthBot
Type: SystemDouble
Rib Width Bottom, wrb
RibSpacing
Type: SystemDouble
Rib Spacing, sr
ShearThickness
Type: SystemDouble
Deck Shear Thickness
UnitWeight
Type: SystemDouble
Deck Unit Weight

Return Value

Type: Int32
The function returns zero if the property data is successfully retrieved; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim DeckType As eDeckType
       Dim ShellType As eShellType
       Dim MatProp As String
       Dim Thickness As Double
       Dim Color As Integer
       Dim Notes As String
       Dim GUID As String
       Dim SlabDepth As Double
       Dim RibDepth As Double
       Dim RibWidthTop As Double
       Dim RibWidthBot As Double
       Dim RibSpacing As Double
       Dim ShearThickness As Double
       Dim UnitWeight As Double

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'set new area property
       ret = SapModel.PropArea.SetDeck("MyShellProp1A", eDeckType.Unfilled, eShellType.ShellThin, "4000Psi", 14)

   'set new area property
       ret = SapModel.PropArea.SetDeckUnfilled(Name:="MyShellProp1A", RibDepth:=1.1, RibWidthTop:=2.3, RibWidthBot:=2.4, RibSpacing:=7, ShearThickness:=5, UnitWeight:=3.1)

   'get area property data
       ret = SapModel.PropArea.GetDeck("MyShellProp1A", DeckType, ShellType, MatProp, Thickness, Color, Notes, GUID)

   'get area property data
       ret = SapModel.PropArea.GetDeckUnfilled("MyShellProp1A", RibDepth, RibWidthTop, RibWidthBot, RibSpacing, ShearThickness, UnitWeight)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also