cPropFrameSDShapeGetTee Method |
Retrieves property data for a Tee shape in a section designer section
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetTee(
string Name,
string ShapeName,
ref string MatProp,
ref string PropName,
ref int Color,
ref double XCenter,
ref double YCenter,
ref double H,
ref double Bf,
ref double Tf,
ref double Tw,
ref double Rotation
)
Function GetTee (
Name As String,
ShapeName As String,
ByRef MatProp As String,
ByRef PropName As String,
ByRef Color As Integer,
ByRef XCenter As Double,
ByRef YCenter As Double,
ByRef H As Double,
ByRef Bf As Double,
ByRef Tf As Double,
ByRef Tw As Double,
ByRef Rotation As Double
) As Integer
int GetTee(
String^ Name,
String^ ShapeName,
String^% MatProp,
String^% PropName,
int% Color,
double% XCenter,
double% YCenter,
double% H,
double% Bf,
double% Tf,
double% Tw,
double% Rotation
)
abstract GetTee :
Name : string *
ShapeName : string *
MatProp : string byref *
PropName : string byref *
Color : int byref *
XCenter : float byref *
YCenter : float byref *
H : float byref *
Bf : float byref *
Tf : float byref *
Tw : float byref *
Rotation : float byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing frame section property that is a section designer section
- ShapeName
- Type: SystemString
The name of an existing Tee shape in the specified frame section property
- MatProp
- Type: SystemString
The name of the material property for the shape
- PropName
- Type: SystemString
This is a blank string or the name of a defined Tee property that has been imported from a section property file.
If it is the name of a defined Tee property, the section dimensions are taken from that property.
- Color
- Type: SystemInt32
The fill color assigned to the shape
- XCenter
- Type: SystemDouble
The X-coordinate of the center of the shape in the section designer coordinate system. [L]
- YCenter
- Type: SystemDouble
The Y-coordinate of the center of the shape in the section designer coordinate system. [L]
- H
- Type: SystemDouble
The section depth. [L]
- Bf
- Type: SystemDouble
The section width. [L]
- Tf
- Type: SystemDouble
The flange thickness. [L]
- Tw
- Type: SystemDouble
The web thickness. [L]
- Rotation
- Type: SystemDouble
The counter clockwise rotation of the shape from its default orientation. [deg]
Return Value
Type:
Int32
Returns zero if the property data is successfully retrieved; otherwise it returns a nonzero value
Remarks
See Also