cPropFrameGetSteelAngle Method |
Retrieves frame section property data for a steel angle frame section.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetSteelAngle(
string Name,
ref string FileName,
ref string MatProp,
ref double T3,
ref double T2,
ref double Tf,
ref double Tw,
ref double r,
ref bool MirrorAbout2,
ref bool MirrorAbout3,
ref int Color,
ref string Notes,
ref string GUID
)
Function GetSteelAngle (
Name As String,
ByRef FileName As String,
ByRef MatProp As String,
ByRef T3 As Double,
ByRef T2 As Double,
ByRef Tf As Double,
ByRef Tw As Double,
ByRef r As Double,
ByRef MirrorAbout2 As Boolean,
ByRef MirrorAbout3 As Boolean,
ByRef Color As Integer,
ByRef Notes As String,
ByRef GUID As String
) As Integer
int GetSteelAngle(
String^ Name,
String^% FileName,
String^% MatProp,
double% T3,
double% T2,
double% Tf,
double% Tw,
double% r,
bool% MirrorAbout2,
bool% MirrorAbout3,
int% Color,
String^% Notes,
String^% GUID
)
abstract GetSteelAngle :
Name : string *
FileName : string byref *
MatProp : string byref *
T3 : float byref *
T2 : float byref *
Tf : float byref *
Tw : float byref *
r : float byref *
MirrorAbout2 : bool byref *
MirrorAbout3 : bool byref *
Color : int byref *
Notes : string byref *
GUID : string byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing frame section property. - FileName
- Type: SystemString
If the section property was imported from a property file,
this is the name of that file. If the section property was not imported, this item is blank. - MatProp
- Type: SystemString
The name of the material property for the section. - T3
- Type: SystemDouble
- T2
- Type: SystemDouble
- Tf
- Type: SystemDouble
- Tw
- Type: SystemDouble
- r
- Type: SystemDouble
The fillet radius. [L] - MirrorAbout2
- Type: SystemBoolean
Indicates whether the section is mirrored about the local 2-axis. - MirrorAbout3
- Type: SystemBoolean
Indicates whether the section is mirrored about the local 3-axis. - Color
- Type: SystemInt32
- Notes
- Type: SystemString
- GUID
- Type: SystemString
The GUID (global unique identifier), if any, assigned to the section.
Return Value
Type:
Int32returns zero if the section property data is successfully retrieved;
otherwise it returns a nonzero value.
Remarks
This function supersedes
GetAngle(String, String, String, Double, Double, Double, Double, Int32, String, String).
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Name As String
Dim FileName As String
Dim MatProp As String
Dim t3 As Double
Dim t2 As Double
Dim tf As Double
Dim tw As Double
Dim r As Double
Dim mirror2 As Boolean
Dim mirror3 As Boolean
Dim Color As Integer
Dim Notes As String
Dim GUID As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropFrame.SetSteelAngle("ANGLE1", "A992Fy50", 6, 4, 0.5, 0.5, 0.5, False, False)
ret = SapModel.PropFrame.GetSteelAngle("ANGLE1", FileName, MatProp, t3, t2, tf, tw, r, mirror2, mirror3, Color, Notes, GUID)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also