cPropFrameGetConcreteTee Method |
Retrieves frame section property data for a concrete tee frame section.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetConcreteTee(
string Name,
ref string FileName,
ref string MatProp,
ref double T3,
ref double T2,
ref double Tf,
ref double TwF,
ref double TwT,
ref bool MirrorAbout3,
ref int Color,
ref string Notes,
ref string GUID
)
Function GetConcreteTee (
Name As String,
ByRef FileName As String,
ByRef MatProp As String,
ByRef T3 As Double,
ByRef T2 As Double,
ByRef Tf As Double,
ByRef TwF As Double,
ByRef TwT As Double,
ByRef MirrorAbout3 As Boolean,
ByRef Color As Integer,
ByRef Notes As String,
ByRef GUID As String
) As Integer
int GetConcreteTee(
String^ Name,
String^% FileName,
String^% MatProp,
double% T3,
double% T2,
double% Tf,
double% TwF,
double% TwT,
bool% MirrorAbout3,
int% Color,
String^% Notes,
String^% GUID
)
abstract GetConcreteTee :
Name : string *
FileName : string byref *
MatProp : string byref *
T3 : float byref *
T2 : float byref *
Tf : float byref *
TwF : float byref *
TwT : float byref *
MirrorAbout3 : bool byref *
Color : int byref *
Notes : string byref *
GUID : string byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing frame section property. - FileName
- Type: SystemString
If the section property was imported from a property file,
this is the name of that file. If the section property was not imported, this item is blank. - MatProp
- Type: SystemString
The name of the material property for the section. - T3
- Type: SystemDouble
- T2
- Type: SystemDouble
- Tf
- Type: SystemDouble
- TwF
- Type: SystemDouble
The web thickness at the flange. [L] - TwT
- Type: SystemDouble
The web thickness at the tip. [L] - MirrorAbout3
- Type: SystemBoolean
Indicates whether the section is mirrored about the local 3-axis. - Color
- Type: SystemInt32
- Notes
- Type: SystemString
- GUID
- Type: SystemString
The GUID (global unique identifier), if any, assigned to the section.
Return Value
Type:
Int32Returns zero if the section property is successfully retrieved;
otherwise it returns a nonzero value.
Remarks
This function supersedes
GetTee(String, String, String, Double, Double, Double, Double, Int32, String, String).
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim FileName As String
Dim MatProp As String
Dim t3 As Double
Dim t2 As Double
Dim tf As Double
Dim twf As Double
Dim twt as Double
Dim mirror3
Dim Color As Integer
Dim Notes As String
Dim GUID As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropFrame.SetConcreteTee("TEE1", "4000Psi", 30, 36, 8, 7, 5, False)
ret = SapModel.PropFrame.GetConcreteTee("TEE1", FileName, MatProp, t3, t2, tf, twf, twt, mirror3, Color, Notes, GUID)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also