cPropFrameSDShapeGetSolidRect Method |
Retrieves property data for a solid rectangular shape in a section designer section
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetSolidRect(
string Name,
string ShapeName,
ref string MatProp,
ref string SSOverwrite,
ref int Color,
ref double XCenter,
ref double YCenter,
ref double H,
ref double W,
ref double Rotation,
ref bool Reinf,
ref string MatRebar
)
Function GetSolidRect (
Name As String,
ShapeName As String,
ByRef MatProp As String,
ByRef SSOverwrite As String,
ByRef Color As Integer,
ByRef XCenter As Double,
ByRef YCenter As Double,
ByRef H As Double,
ByRef W As Double,
ByRef Rotation As Double,
ByRef Reinf As Boolean,
ByRef MatRebar As String
) As Integer
int GetSolidRect(
String^ Name,
String^ ShapeName,
String^% MatProp,
String^% SSOverwrite,
int% Color,
double% XCenter,
double% YCenter,
double% H,
double% W,
double% Rotation,
bool% Reinf,
String^% MatRebar
)
abstract GetSolidRect :
Name : string *
ShapeName : string *
MatProp : string byref *
SSOverwrite : string byref *
Color : int byref *
XCenter : float byref *
YCenter : float byref *
H : float byref *
W : float byref *
Rotation : float byref *
Reinf : bool byref *
MatRebar : string byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing frame section property that is a section designer section
- ShapeName
- Type: SystemString
The name of an existing solid rectangle shape in the specified frame section property
- MatProp
- Type: SystemString
The name of the material property for the shape
- SSOverwrite
- Type: SystemString
This is a blank string, Default, or the name of a defined stress-strain curve.
If this item is a blank string or Default,
the shape stress-strain curve is based on the assigned material property.
- Color
- Type: SystemInt32
The fill color assigned to the shape
- XCenter
- Type: SystemDouble
The X-coordinate of the center of the shape in the section designer coordinate system. [L]
- YCenter
- Type: SystemDouble
The Y-coordinate of the center of the shape in the section designer coordinate system. [L]
- H
- Type: SystemDouble
The section depth. [L]
- W
- Type: SystemDouble
The section width. [L]
- Rotation
- Type: SystemDouble
The counter clockwise rotation of the shape from its default orientation. [deg]
- Reinf
- Type: SystemBoolean
This item is True when there is edge and corner reinforcing steel associated with the shape.
The MatProp item must refer to a concrete material for this item to be True.
- MatRebar
- Type: SystemString
The material property for the edge and corner reinforcing steel associated with the shape.
This item applies only when the MatProp item is a concrete material
and the Reinf item is True.
Return Value
Type:
Int32
Returns zero if the property data is successfully retrieved; otherwise it returns a nonzero value
Remarks
See Also