cPropFrameGetRebarBeam Method |
Retrieves beam rebar data for frame sections.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetRebarBeam(
string Name,
ref string MatPropLong,
ref string MatPropConfine,
ref double CoverTop,
ref double CoverBot,
ref double TopLeftArea,
ref double TopRightArea,
ref double BotLeftArea,
ref double BotRightArea
)
Function GetRebarBeam (
Name As String,
ByRef MatPropLong As String,
ByRef MatPropConfine As String,
ByRef CoverTop As Double,
ByRef CoverBot As Double,
ByRef TopLeftArea As Double,
ByRef TopRightArea As Double,
ByRef BotLeftArea As Double,
ByRef BotRightArea As Double
) As Integer
int GetRebarBeam(
String^ Name,
String^% MatPropLong,
String^% MatPropConfine,
double% CoverTop,
double% CoverBot,
double% TopLeftArea,
double% TopRightArea,
double% BotLeftArea,
double% BotRightArea
)
abstract GetRebarBeam :
Name : string *
MatPropLong : string byref *
MatPropConfine : string byref *
CoverTop : float byref *
CoverBot : float byref *
TopLeftArea : float byref *
TopRightArea : float byref *
BotLeftArea : float byref *
BotRightArea : float byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing frame section property. - MatPropLong
- Type: SystemString
The name of the rebar material property for the longitudinal rebar. - MatPropConfine
- Type: SystemString
The name of the rebar material property for the confinement rebar. - CoverTop
- Type: SystemDouble
The distance from the top of the beam to the centroid of the top
longitudinal reinforcement. [L] - CoverBot
- Type: SystemDouble
The distance from the bottom of the beam to the centroid of the
bottom longitudinal reinforcement. [L] - TopLeftArea
- Type: SystemDouble
The total area of longitudinal reinforcement at the
top left end of the beam. [L2] - TopRightArea
- Type: SystemDouble
The total area of longitudinal reinforcement at the
top right end of the beam. [L2] - BotLeftArea
- Type: SystemDouble
The total area of longitudinal reinforcement at the
bottom left end of the beam. [L2] - BotRightArea
- Type: SystemDouble
The total area of longitudinal reinforcement at the
bottom right end of the beam. [L2]
Return Value
Type:
Int32Returns zero if the rebar data is successfully retrieved;
otherwise it returns a nonzero value.
Remarks
This function applies only to the following section types. Calling this function for any other type of frame section property returns an error.
The material assigned to the specified frame section property must be concrete or this function returns an error.
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim RebarName As String
Dim MatPropLong As String
Dim MatPropConfine As String
Dim CoverTop As Double
Dim CoverBot As Double
Dim TopLeftArea As Double
Dim TopRightArea As Double
Dim BotLeftArea As Double
Dim BotRightArea As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropFrame.SetRectangle("R1", "4000Psi", 20, 12)
ret = SapModel.PropMaterial.AddQuick(RebarName, eMatType.Rebar, , , , , eMatTypeRebar.ASTM_A706)
ret = SapModel.PropFrame.SetRebarBeam("R1", RebarName, RebarName, 3.5, 3, 4.1, 4.2, 4.3, 4.4)
ret = SapModel.PropFrame.GetRebarBeam("R1", MatPropLong, MatPropConfine, CoverTop, CoverBot, TopLeftArea, TopRightArea, BotLeftArea, BotRightArea)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also