cPropAreaGetTypeOAPI Method

Retrieves the property type for the specified area property.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetTypeOAPI(
	string Name,
	ref int PropType
)

Parameters

Name
Type: SystemString
The name of an existing area property.
PropType
Type: SystemInt32
This is 1, 2 or 3, indicating the type of area property.
ValueType
1Shell
2Plane
3Asolid

Return Value

Type: Int32
Returns zero if the type is successfully retrieved; otherwise it returns nonzero.
Remarks
Plane and Asolid area properties are not supported in ETABS.
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim PropType As Integer

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'get area property type
       ret = SapModel.PropArea.GetTypeOAPI("SLAB1", PropType)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also