cPropFrameSDShapeGetReinfCorner Method |
Retrieves corner point reinforcing data for solid rectangle,
circle and polygon shapes in a section designer property
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetReinfCorner(
string Name,
string ShapeName,
ref int NumberItems,
ref int[] PointNum,
ref string[] RebarSize
)
Function GetReinfCorner (
Name As String,
ShapeName As String,
ByRef NumberItems As Integer,
ByRef PointNum As Integer(),
ByRef RebarSize As String()
) As Integer
int GetReinfCorner(
String^ Name,
String^ ShapeName,
int% NumberItems,
array<int>^% PointNum,
array<String^>^% RebarSize
)
abstract GetReinfCorner :
Name : string *
ShapeName : string *
NumberItems : int byref *
PointNum : int[] byref *
RebarSize : string[] byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing frame section property that is a section designer section
- ShapeName
- Type: SystemString
The name of an existing solid rectangle shape in the specified frame section property
- NumberItems
- Type: SystemInt32
The number of edges in the shape
- PointNum
- Type: SystemInt32
This is an array that includes the corner point number in the shape
- RebarSize
- Type: SystemString
This is an array that includes None or the name of a defined rebar, indicating the rebar assignment to the considered corner point
Return Value
Type:
Int32
Returns zero if the property data is successfully retrieved; otherwise it returns a nonzero value
Remarks
See Also