cAnalysisResultsAreaStressShell Method |
Reports the area stresses for the specified area elements that are assigned shell section properties.
Stresses are reported at each point element associated with the area element
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint AreaStressShell(
string Name,
eItemTypeElm ItemTypeElm,
ref int NumberResults,
ref string[] Obj,
ref string[] Elm,
ref string[] PointElm,
ref string[] LoadCase,
ref string[] StepType,
ref double[] StepNum,
ref double[] S11Top,
ref double[] S22Top,
ref double[] S12Top,
ref double[] SMaxTop,
ref double[] SMinTop,
ref double[] SAngleTop,
ref double[] SVMTop,
ref double[] S11Bot,
ref double[] S22Bot,
ref double[] S12Bot,
ref double[] SMaxBot,
ref double[] SMinBot,
ref double[] SAngleBot,
ref double[] SVMBot,
ref double[] S13Avg,
ref double[] S23Avg,
ref double[] SMaxAvg,
ref double[] SAngleAvg
)
Function AreaStressShell (
Name As String,
ItemTypeElm As eItemTypeElm,
ByRef NumberResults As Integer,
ByRef Obj As String(),
ByRef Elm As String(),
ByRef PointElm As String(),
ByRef LoadCase As String(),
ByRef StepType As String(),
ByRef StepNum As Double(),
ByRef S11Top As Double(),
ByRef S22Top As Double(),
ByRef S12Top As Double(),
ByRef SMaxTop As Double(),
ByRef SMinTop As Double(),
ByRef SAngleTop As Double(),
ByRef SVMTop As Double(),
ByRef S11Bot As Double(),
ByRef S22Bot As Double(),
ByRef S12Bot As Double(),
ByRef SMaxBot As Double(),
ByRef SMinBot As Double(),
ByRef SAngleBot As Double(),
ByRef SVMBot As Double(),
ByRef S13Avg As Double(),
ByRef S23Avg As Double(),
ByRef SMaxAvg As Double(),
ByRef SAngleAvg As Double()
) As Integer
int AreaStressShell(
String^ Name,
eItemTypeElm ItemTypeElm,
int% NumberResults,
array<String^>^% Obj,
array<String^>^% Elm,
array<String^>^% PointElm,
array<String^>^% LoadCase,
array<String^>^% StepType,
array<double>^% StepNum,
array<double>^% S11Top,
array<double>^% S22Top,
array<double>^% S12Top,
array<double>^% SMaxTop,
array<double>^% SMinTop,
array<double>^% SAngleTop,
array<double>^% SVMTop,
array<double>^% S11Bot,
array<double>^% S22Bot,
array<double>^% S12Bot,
array<double>^% SMaxBot,
array<double>^% SMinBot,
array<double>^% SAngleBot,
array<double>^% SVMBot,
array<double>^% S13Avg,
array<double>^% S23Avg,
array<double>^% SMaxAvg,
array<double>^% SAngleAvg
)
abstract AreaStressShell :
Name : string *
ItemTypeElm : eItemTypeElm *
NumberResults : int byref *
Obj : string[] byref *
Elm : string[] byref *
PointElm : string[] byref *
LoadCase : string[] byref *
StepType : string[] byref *
StepNum : float[] byref *
S11Top : float[] byref *
S22Top : float[] byref *
S12Top : float[] byref *
SMaxTop : float[] byref *
SMinTop : float[] byref *
SAngleTop : float[] byref *
SVMTop : float[] byref *
S11Bot : float[] byref *
S22Bot : float[] byref *
S12Bot : float[] byref *
SMaxBot : float[] byref *
SMinBot : float[] byref *
SAngleBot : float[] byref *
SVMBot : float[] byref *
S13Avg : float[] byref *
S23Avg : float[] byref *
SMaxAvg : float[] byref *
SAngleAvg : float[] byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing area object, area element or group of objects,
depending on the value of the ItemTypeElm item
- ItemTypeElm
- Type: ETABS2016eItemTypeElm
This is one of the following items in the eItemTypeElm
enumeration.
If this item is ObjectElm, the result request is for the area elements
corresponding to the area object specified by the Name item.
If this item is Element, the result request is for the area
element specified by the Name item.
If this item is GroupElm, the result request is for the area elements
corresponding to all area objects included in the group specified by the Name item.
If this item is SelectionElm, the result request is for area elements
corresponding to all selected area objects and the Name item is ignored.
- NumberResults
- Type: SystemInt32
The total number of results returned by the program
- Obj
- Type: SystemString
This is an array that includes the area object name associated with each result, if any
- Elm
- Type: SystemString
This is an array that includes the area element name associated with each result
- PointElm
- Type: SystemString
This is an array that includes the name of the point element where the results are reported
- LoadCase
- Type: SystemString
This is an array that includes the name of the analysis case or load combination associated with each result
- StepType
- Type: SystemString
This is an array that includes the step type, if any, for each result
- StepNum
- Type: SystemDouble
This is an array that includes the step number, if any, for each result
- S11Top
- Type: SystemDouble
The area element internal S11 at the top of the specified area element, at the specified point element location,
reported in the area element local coordinate system. [F/L2]
- S22Top
- Type: SystemDouble
The area element internal S22 at the top of the specified area element, at the specified point element location,
reported in the area element local coordinate system. [F/L2]
- S12Top
- Type: SystemDouble
The area element internal S12 at the top of the specified area element, at the specified point element location,
reported in the area element local coordinate system. [F/L2]
- SMaxTop
- Type: SystemDouble
The area element maximum principal stress at the top of the specified area element,
at the specified point element location. [F/L2]
- SMinTop
- Type: SystemDouble
The area element minimum principal stress at the top of the specified area element,
at the specified point element location. [F/L2]
- SAngleTop
- Type: SystemDouble
The angle measured counter clockwise (when the local 3 axis is pointing toward you)
from the area local 1 axis to the direction of the maximum principal stress,
at the top of the specified area element. [deg]
- SVMTop
- Type: SystemDouble
The area element internal top Von Mises stress at the specified point element. [F/L2]
- S11Bot
- Type: SystemDouble
The area element internal S11 at the bottom of the specified area element, at the specified point element location,
reported in the area element local coordinate system. [F/L2]
- S22Bot
- Type: SystemDouble
The area element internal S22 at the bottom of the specified area element, at the specified point element location,
reported in the area element local coordinate system. [F/L2]
- S12Bot
- Type: SystemDouble
The area element internal S12 at the bottom of the specified area element, at the specified point element location,
reported in the area element local coordinate system. [F/L2]
- SMaxBot
- Type: SystemDouble
The area element maximum principal stress at the bottom of the specified area element,
at the specified point element location. [F/L2]
- SMinBot
- Type: SystemDouble
The area element minimum principal stress at the bottom of the specified area element,
at the specified point element location. [F/L2]
- SAngleBot
- Type: SystemDouble
The angle measured counter clockwise (when the local 3 axis is pointing toward you)
from the area local 1 axis to the direction of the maximum principal stress,
at the bottom of the specified area element. [deg]
- SVMBot
- Type: SystemDouble
The area element internal bottom Von Mises stress at the specified point element. [F/L2]
- S13Avg
- Type: SystemDouble
The area element average S13 out-of-plane shear stress at the specified point element.
This item is only reported for area elements with properties that allow plate bending behavior. [F/L2]
- S23Avg
- Type: SystemDouble
The area element average S23 out-of-plane shear stress at the specified point element.
This item is only reported for area elements with properties that allow plate bending behavior. [F/L2]
- SMaxAvg
- Type: SystemDouble
The area element maximum average out-of-plane shear stress.
It is equal to the square root of the sum of the squares of S13Avg and S23Avg.
This item is only reported for area elements with properties that allow plate bending behavior. [F/L2]
- SAngleAvg
- Type: SystemDouble
The angle measured counter clockwise (when the local 3 axis is pointing toward you)
from the area local 1 axis to the direction of SMaxAvg.
This item is only reported for area elements with properties that allow plate bending behavior. [deg]
Return Value
Type:
Int32
Returns zero if the stresses are successfully recovered, otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim NumberResults As Integer
Dim Obj() As String
Dim ObjSta() As Double
Dim Elm() As String
Dim ElmSta() As Double
Dim LoadCase() As String
Dim StepType() As String
Dim StepNum() As Double
Dim S11Top() As Double
Dim S22Top() As Double
Dim S12Top() As Double
Dim SMaxTop() As Double
Dim SMinTop() As Double
Dim SAngleTop() As Double
Dim SVMTop() As Double
Dim S11Bot() As Double
Dim S22Bot() As Double
Dim S12Bot() As Double
Dim SMaxBot() As Double
Dim SMinBot() As Double
Dim SAngleBot() As Double
Dim SVMBot() As Double
Dim S13Avg() As Double
Dim S23Avg() As Double
Dim SMaxAvg() As Double
Dim SAngleAvg() As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
System.IO.Directory.CreateDirectory("c:\CSI_API_temp")
ret = SapModel.File.Save("C:\CSI_API_temp\example.edb")
ret = SapModel.Analyze.RunAnalysis()
ret = SapModel.Results.Setup.DeselectAllCasesAndCombosForOutput()
ret = SapModel.Results.Setup.SetCaseSelectedForOutput("DEAD")
ret = SapModel.Results.AreaStressShell("1", eItemTypeElm.ObjectElm, NumberResults, Obj, Elm, PointElm, LoadCase, StepType, StepNum, S11Top, S22Top, S12Top, SMaxTop, SMinTop, SAngleTop, SVMTop, S11Bot, S22Bot, S12Bot, SMaxBot, SMinBot, SAngleBot, SVMBot, S13Avg, S23Avg, SMaxAvg, SAngleAvg)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also