cFrameObjGetOutputStations Method |
Retrieves frame object output station data
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetOutputStations(
string Name,
ref int MyType,
ref double MaxSegSize,
ref int MinSections,
ref bool NoOutPutAndDesignAtElementEnds,
ref bool NoOutPutAndDesignAtPointLoads
)
Function GetOutputStations (
Name As String,
ByRef MyType As Integer,
ByRef MaxSegSize As Double,
ByRef MinSections As Integer,
ByRef NoOutPutAndDesignAtElementEnds As Boolean,
ByRef NoOutPutAndDesignAtPointLoads As Boolean
) As Integer
int GetOutputStations(
String^ Name,
int% MyType,
double% MaxSegSize,
int% MinSections,
bool% NoOutPutAndDesignAtElementEnds,
bool% NoOutPutAndDesignAtPointLoads
)
abstract GetOutputStations :
Name : string *
MyType : int byref *
MaxSegSize : float byref *
MinSections : int byref *
NoOutPutAndDesignAtElementEnds : bool byref *
NoOutPutAndDesignAtPointLoads : bool byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing frame object
- MyType
- Type: SystemInt32
This is either 1 or 2 indicating how the output stations are specified
- maximum segment size, that is, maximum station spacing
- minimum number of stations
- MaxSegSize
- Type: SystemDouble
The maximum segment size, that is, the maximum station spacing. This item applies only when MyType = 1. [L]
- MinSections
- Type: SystemInt32
The minimum number of stations. This item applies only when MyType = 2.
- NoOutPutAndDesignAtElementEnds
- Type: SystemBoolean
If this item is True, no additional output stations are added at the ends of line elements
when the frame object is internally meshed. In ETABS, this item will always be False.
- NoOutPutAndDesignAtPointLoads
- Type: SystemBoolean
If this item is True, no additional output stations are added at point load locations.
In ETABS, this item will always be False.
Return Value
Type:
Int32
Returns zero if the data is successfully retrieved, otherwise it returns a nonzero value
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim MyType As Integer
Dim MaxSegSize As Double
Dim MinSections As Integer
Dim NoOutPutAndDesignAtElementEnds As Boolean
Dim NoOutPutAndDesignAtPointLoads As Boolean
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.FrameObj.GetOutputStations("15", MyType, MaxSegSize, MinSections, NoOutPutAndDesignAtElementEnds, NoOutPutAndDesignAtPointLoads)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also