cAnalyzeGetSolverOption_1 Method |
Retrieves the model solver options.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetSolverOption_1(
ref int SolverType,
ref int SolverProcessType,
ref bool Force32BitSolver,
ref string StiffCase
)
Function GetSolverOption_1 (
ByRef SolverType As Integer,
ByRef SolverProcessType As Integer,
ByRef Force32BitSolver As Boolean,
ByRef StiffCase As String
) As Integer
int GetSolverOption_1(
int% SolverType,
int% SolverProcessType,
bool% Force32BitSolver,
String^% StiffCase
)
abstract GetSolverOption_1 :
SolverType : int byref *
SolverProcessType : int byref *
Force32BitSolver : bool byref *
StiffCase : string byref -> int
Parameters
- SolverType
- Type: SystemInt32
This is 0, 1 or 2, indicating the solver type.
- 0 = Standard solver
- 1 = Advanced solver
- 2 = Multi-threaded solver
- SolverProcessType
- Type: SystemInt32
This is 0, 1 or 2, indicating the process the analysis is run.
- 0 = Auto (program determined)
- 1 = GUI process
- 2 = Separate process
- Force32BitSolver
- Type: SystemBoolean
This is True if the analysis is always run using 32-bit,
even on 64-bit computers. - StiffCase
- Type: SystemString
The name of the load case used when outputting the mass
and stiffness matrices to text files.
If this item is blank, no matrices are output.
Return Value
Type:
Int32
Returns zero if the options are successfully retrieved;
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim SolverType As Integer
Dim SolverProcessType As Integer
Dim Force32BitSolver As Boolean
Dim StiffCase As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.Analyze.GetSolverOption_1(SolverType, SolverProcessType, Force32BitSolver, StiffCase)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also