cPropFrameSetPlate Method

Initializes a solid plate frame section property. If this function is called for an existing frame section property, all items for the section are reset to their default value.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int SetPlate(
	string Name,
	string MatProp,
	double T3,
	double T2,
	int Color = -1,
	string Notes = "",
	string GUID = ""
)

Parameters

Name
Type: SystemString
The name of an existing or new frame section property. If this is an existing property, that property is modified; otherwise, a new property is added.
MatProp
Type: SystemString
The name of the material property for the section.
T3
Type: SystemDouble
T2
Type: SystemDouble
Color (Optional)
Type: SystemInt32
Notes (Optional)
Type: SystemString
GUID (Optional)
Type: SystemString
The GUID (global unique identifier), if any, assigned to the section. If this item is input as Default, the program assigns a GUID to the section.

Return Value

Type: Int32
Returns zero if the section property is successfully initialized; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'set new frame section property
       ret = SapModel.PropFrame.SetPlate("R1", "A992Fy50", 20, 12)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also