cGridSysGetGridSys Method |
Retrieves the grid system specified by the Name item.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetGridSys(
string Name,
ref double x,
ref double y,
ref double RZ
)
Function GetGridSys (
Name As String,
ByRef x As Double,
ByRef y As Double,
ByRef RZ As Double
) As Integer
int GetGridSys(
String^ Name,
double% x,
double% y,
double% RZ
)
abstract GetGridSys :
Name : string *
x : float byref *
y : float byref *
RZ : float byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing grid system.
- x
- Type: SystemDouble
The global X grid of the origin of the grid system. [L]
- y
- Type: SystemDouble
The global Y grid of the origin of the grid system. [L]
- RZ
- Type: SystemDouble
The rotation of an axis of the new grid system relative to the
global grid system is defined as follows:
(1) Rotate the grid system about the positive global Z-axis
as defined by the RZ item. [deg]
Return Value
Type:
Int32
Returns zero if the grid system data is successfully retrieved,
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.GridSys.SetGridSys("GridSysA", 1000, 1000, 0, 0, 0, 0)
ret = SapModel.GridSys.GetGridSys("GridSysA", x, y, z, RZ)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also