cAnalysisResultsAssembledJointMass Method |
Reports the assembled joint masses for the specified point elements
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint AssembledJointMass(
string Name,
eItemTypeElm ItemTypeElm,
ref int NumberResults,
ref string[] PointElm,
ref double[] U1,
ref double[] U2,
ref double[] U3,
ref double[] R1,
ref double[] R2,
ref double[] R3
)
Function AssembledJointMass (
Name As String,
ItemTypeElm As eItemTypeElm,
ByRef NumberResults As Integer,
ByRef PointElm As String(),
ByRef U1 As Double(),
ByRef U2 As Double(),
ByRef U3 As Double(),
ByRef R1 As Double(),
ByRef R2 As Double(),
ByRef R3 As Double()
) As Integer
int AssembledJointMass(
String^ Name,
eItemTypeElm ItemTypeElm,
int% NumberResults,
array<String^>^% PointElm,
array<double>^% U1,
array<double>^% U2,
array<double>^% U3,
array<double>^% R1,
array<double>^% R2,
array<double>^% R3
)
abstract AssembledJointMass :
Name : string *
ItemTypeElm : eItemTypeElm *
NumberResults : int byref *
PointElm : string[] byref *
U1 : float[] byref *
U2 : float[] byref *
U3 : float[] byref *
R1 : float[] byref *
R2 : float[] byref *
R3 : float[] byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing point object, point element, or group of objects
depending on the value of the ItemTypeElm item.
- ItemTypeElm
- Type: ETABS2016eItemTypeElm
This is one of the following items in the eItemTypeElm
enumeration.
If this item is ObjectElm, the result request is for the point
element corresponding to the point object specified by the Name item.
If this item is Element, the result request is for the point
element specified by the Name item.
If this item is GroupElm, the result request is for all point
elements directly or indirectly specified in the group specified by the Name item.
If this item is SelectionElm, the result request is for all point
elements directly or indirectly selected and the Name item is ignored.
- NumberResults
- Type: SystemInt32
The total number of results returned by the program.
- PointElm
- Type: SystemString
This is an array that includes the point element name associated with each result
- U1
- Type: SystemDouble
This array contains the translational mass in the point element local 1 direction for each result. [M]
- U2
- Type: SystemDouble
This array contains the translational mass in the point element local 2 direction for each result. [M]
- U3
- Type: SystemDouble
This array contains the translational mass in the point element local 3 direction for each result. [M]
- R1
- Type: SystemDouble
This array contains the rotational mass moment of inertia about the point element local 1 axis for each result. [ML2]
- R2
- Type: SystemDouble
This array contains the rotational mass moment of inertia about the point element local 2 axis for each result. [ML2]
- R3
- Type: SystemDouble
This array contains the rotational mass moment of inertia about the point element local 3 axis for each result. [ML2]
Return Value
Type:
Int32
Returns zero if the masses are successfully recovered, otherwise it returns a nonzero value
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim NumberResults As Integer
Dim Obj() As String
Dim Elm() As String
Dim PointElm() As String
Dim U1() As Double
Dim U2() As Double
Dim U3() As Double
Dim R1() As Double
Dim R2() As Double
Dim R3() As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
System.IO.Directory.CreateDirectory("c:\CSI_API_temp")
ret = SapModel.File.Save("C:\CSI_API_temp\example.edb")
ret = SapModel.Analyze.RunAnalysis()
ret = SapModel.Results.AssembledJointMass("ALL", eItemTypeElm.GroupElm, NumberResults, PointElm, U1, U2, U3, R1, R2, R3)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also