cPointObjGetNameListOnStory Method

Retrieves the names of the defined point objects on a given story.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetNameListOnStory(
	string StoryName,
	ref int NumberNames,
	ref string[] MyName
)

Parameters

StoryName
Type: SystemString
The name of an existing story.
NumberNames
Type: SystemInt32
The number of point object names retrieved by the program.
MyName
Type: SystemString
This is a one-dimensional array of point object names. The MyName array is created as a dynamic, zero-based, array by the API user:

Dim MyName() as String

The array is dimensioned to (NumberNames – 1) inside the ETABS program, filled with the names, and returned to the API user.

Return Value

Type: Int32
Returns zero if the names are successfully retrieved, otherwise it returns nonzero.
Remarks
Examples
VB
Public Sub Example()
   Dim SapModel As cSapModel
   Dim EtabsObject As cOAPI
   Dim ret As Integer = -1

'create ETABS object
   EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

'start ETABS application
  ret = EtabsObject.ApplicationStart()

'create SapModel object
   SapModel = EtabsObject.SapModel

'initialize model
   ret = SapModel.InitializeNewModel()

'create steel deck template model
   ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)

'get point object names
   ret = SapModel.PointObj.GetNameListOnStory("Story2", NumberNames, MyName)

'close ETABS
   EtabsObject.ApplicationExit(False)

'clean up variables
   SapModel = Nothing
   EtabsObject = Nothing

End Sub
See Also