cPropAreaCount Method

Returns the total number of defined area properties in the model. If desired, counts can be returned for all area properties of a specified type in the model.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int Count(
	int PropType = 0
)

Parameters

PropType (Optional)
Type: SystemInt32
This optional value is 0, 1, 2 or 3, indicating the type of area properties included in the count.
ValueType
0All
1Shell
2Plane
3Asolid

Return Value

Type: Int32
The total number of defined area properties in the model.
Remarks
Plane and Asolid area properties are not supported in ETABS.
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim Count as Integer

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'return number of defined area properties of all types
       Count = SapModel.PropArea.Count

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also