cAnalyzeSetSolverOption_1 Method |
Sets the model solver options.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetSolverOption_1(
int SolverType,
int SolverProcessType,
bool Force32BitSolver,
string StiffCase = ""
)
Function SetSolverOption_1 (
SolverType As Integer,
SolverProcessType As Integer,
Force32BitSolver As Boolean,
Optional StiffCase As String = ""
) As Integer
int SetSolverOption_1(
int SolverType,
int SolverProcessType,
bool Force32BitSolver,
String^ StiffCase = L""
)
abstract SetSolverOption_1 :
SolverType : int *
SolverProcessType : int *
Force32BitSolver : bool *
?StiffCase : string
(* Defaults:
let _StiffCase = defaultArg StiffCase ""
*)
-> int
Parameters
- SolverType
- Type: SystemInt32
This is 0, 1 or 2, indicating the solver type.
- 0 = Standard solver
- 1 = Advanced solver
- 2 = Multi-threaded solver
- SolverProcessType
- Type: SystemInt32
This is 0, 1 or 2, indicating the process the analysis is run.
- 0 = Auto (program determined)
- 1 = GUI process
- 2 = Separate process
- Force32BitSolver
- Type: SystemBoolean
This is True if the analysis is always run using 32-bit,
even on 64-bit computers. - StiffCase (Optional)
- Type: SystemString
The name of the load case used when outputting the mass
and stiffness matrices to text files.
If this item is blank, no matrices are output.
Return Value
Type:
Int32
Returns zero if the options are successfully set;
otherwise it returns a nonzero value.
Remarks
'''
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.Analyze.SetSolverOption_1(1, 1, True, "DEAD")
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also