cPropAreaSetShellDesign Method |
Assigns the design parameters for shell-type area properties.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetShellDesign(
string Name,
string MatProp,
int SteelLayoutOption,
double DesignCoverTopDir1,
double DesignCoverTopDir2,
double DesignCoverBotDir1,
double DesignCoverBotDir2
)
Function SetShellDesign (
Name As String,
MatProp As String,
SteelLayoutOption As Integer,
DesignCoverTopDir1 As Double,
DesignCoverTopDir2 As Double,
DesignCoverBotDir1 As Double,
DesignCoverBotDir2 As Double
) As Integer
int SetShellDesign(
String^ Name,
String^ MatProp,
int SteelLayoutOption,
double DesignCoverTopDir1,
double DesignCoverTopDir2,
double DesignCoverBotDir1,
double DesignCoverBotDir2
)
abstract SetShellDesign :
Name : string *
MatProp : string *
SteelLayoutOption : int *
DesignCoverTopDir1 : float *
DesignCoverTopDir2 : float *
DesignCoverBotDir1 : float *
DesignCoverBotDir2 : float -> int
Parameters
- Name
- Type: SystemString
The name of an existing shell-type area property. - MatProp
- Type: SystemString
The name of the material property for the area property. - SteelLayoutOption
- Type: SystemInt32
This is 0, 1 or 2 indicating, the rebar layout option.
Value | Layout |
---|
0 | Default |
1 | One layer |
2 | Two layers |
- DesignCoverTopDir1
- Type: SystemDouble
The cover to the centroid of the top reinforcing steel
running in the local 1 axis direction of the area object. [L]
This item applies only when SteelLayoutOption = 1 or 2.
- DesignCoverTopDir2
- Type: SystemDouble
The cover to the centroid of the top reinforcing
steel running in the local 2 axis direction of the area object. [L]
This item applies only when SteelLayoutOption = 1 or 2.
- DesignCoverBotDir1
- Type: SystemDouble
The cover to the centroid of the bottom reinforcing steel
running in the local 1 axis direction of the area object. [L]
This item applies only when SteelLayoutOption = 2.
- DesignCoverBotDir2
- Type: SystemDouble
The cover to the centroid of the bottom reinforcing steel
running in the local 2 axis direction of the area object. [L]
This item applies only when SteelLayoutOption = 2.
Return Value
Type:
Int32Returns zero if the parameters are successfully assigned;
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropArea.SetShellDesign("SLAB1", "A615Gr60", 2, 2, 3, 2.5, 3.5)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also