Adds a new load pattern.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint Add(
string Name,
eLoadPatternType MyType,
double SelfWTMultiplier = 0,
bool AddAnalysisCase = true
)
Function Add (
Name As String,
MyType As eLoadPatternType,
Optional SelfWTMultiplier As Double = 0,
Optional AddAnalysisCase As Boolean = true
) As Integer
int Add(
String^ Name,
eLoadPatternType MyType,
double SelfWTMultiplier = 0,
bool AddAnalysisCase = true
)
abstract Add :
Name : string *
MyType : eLoadPatternType *
?SelfWTMultiplier : float *
?AddAnalysisCase : bool
(* Defaults:
let _SelfWTMultiplier = defaultArg SelfWTMultiplier 0
let _AddAnalysisCase = defaultArg AddAnalysisCase true
*)
-> int
Parameters
- Name
- Type: SystemString
The name for the new load pattern.
- MyType
- Type: ETABS2016eLoadPatternType
This is one of the items in the eLoadPatternType enumeration.
- SelfWTMultiplier (Optional)
- Type: SystemDouble
The self weight multiplier for the new load pattern.
- AddAnalysisCase (Optional)
- Type: SystemBoolean
If this item is True, a linear static load case corresponding
to the new load pattern is added.
Return Value
Type:
Int32
Returns 0 if the load pattern is successfully added; otherwise it returns nonzero.
Remarks
An error is returned if the
Name item is already used
for an existing load pattern.
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.LoadPatterns.Add("LIVE1A", eLoadPatternType.Live)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also