cLoadPatterns Interface

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
public interface cLoadPatterns

The cLoadPatterns type exposes the following members.

Properties
  NameDescription
Public propertyAutoSeismic
Public propertyAutoWind
Top
Methods
  NameDescription
Public methodAdd
Adds a new load pattern.
Public methodChangeName
Applies a new name to a load pattern.
Public methodCount
Retrieves the number of defined load patterns.
Public methodDelete
Deletes the specified load pattern.
Public methodGetAutoSeismicCode
Retrieves the code name used for auto seismic parameters in Quake-type load patterns.
Public methodGetAutoWindCode
Retrieves the code name used for auto wind parameters in Wind-type load patterns.
Public methodGetLoadType
Retrieves the load type for a specified load pattern.
Public methodGetNameList
Retrieves the names of all defined load cases.
Public methodGetSelfWTMultiplier
Retrieves the self weight multiplier for a specified load pattern.
Public methodSetLoadType
Assigns a load type to a load pattern.
Public methodSetSelfWTMultiplier
Assigns a self weight multiplier to a load case.
Top
See Also