cPropMaterialGetMassSource Method |
DEPRECATED Retrieves the mass source for the model.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetMassSource(
ref int MyOption,
ref int NumberLoads,
ref string[] LoadPat,
ref double[] SF
)
Function GetMassSource (
ByRef MyOption As Integer,
ByRef NumberLoads As Integer,
ByRef LoadPat As String(),
ByRef SF As Double()
) As Integer
int GetMassSource(
int% MyOption,
int% NumberLoads,
array<String^>^% LoadPat,
array<double>^% SF
)
abstract GetMassSource :
MyOption : int byref *
NumberLoads : int byref *
LoadPat : string[] byref *
SF : float[] byref -> int
Parameters
- MyOption
- Type: SystemInt32
This is 1, 2 or 3, indicating the mass source option.
Value | Option |
---|
1 | From element self mass and additional masses |
2 | From loads |
3 | From element self mass and additional masses and loads |
- NumberLoads
- Type: SystemInt32
The number of load patterns from which mass is obtained.
This item applies only when MyOption is 2 or 3. - LoadPat
- Type: SystemString
This is an array of the names of the load patterns from which mass is obtained.
This item applies only when MyOption is 2 or 3. - SF
- Type: SystemDouble
Return Value
Type:
Int32Returns zero if the mass source is successfully retrieved;
otherwise it returns a nonzero value.
Remarks
This function is DEPRECATED. Please use
GetMassSource_1(Boolean, Boolean, Boolean, Int32, String, Double)
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim MyLoadPat() As String
Dim MySF() As Double
Dim MyOption As Integer
Dim NumberLoads As Integer
Dim LoadPat() As String
Dim sf() As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ReDim MyLoadPat(1)
ReDim MySF(1)
MyLoadPat(0) = "DEAD"
MyLoadPat(1) = "LIVE"
MySF(0) = 1
MySF(1) = 0.2
ret = SapModel.PropMaterial.SetMassSource(3, 2, MyLoadPat, MySF)
ret = SapModel.PropMaterial.GetMassSource(MyOption, NumberLoads, LoadPat, sf)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also