cPropFrameSetRebarBeam Method |
Assigns beam rebar data to frame sections.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetRebarBeam(
string Name,
string MatPropLong,
string MatPropConfine,
double CoverTop,
double CoverBot,
double TopLeftArea,
double TopRightArea,
double BotLeftArea,
double BotRightArea
)
Function SetRebarBeam (
Name As String,
MatPropLong As String,
MatPropConfine As String,
CoverTop As Double,
CoverBot As Double,
TopLeftArea As Double,
TopRightArea As Double,
BotLeftArea As Double,
BotRightArea As Double
) As Integer
int SetRebarBeam(
String^ Name,
String^ MatPropLong,
String^ MatPropConfine,
double CoverTop,
double CoverBot,
double TopLeftArea,
double TopRightArea,
double BotLeftArea,
double BotRightArea
)
abstract SetRebarBeam :
Name : string *
MatPropLong : string *
MatPropConfine : string *
CoverTop : float *
CoverBot : float *
TopLeftArea : float *
TopRightArea : float *
BotLeftArea : float *
BotRightArea : float -> int
Parameters
- Name
- Type: SystemString
The name of an existing frame section property. - MatPropLong
- Type: SystemString
The name of the rebar material property for the longitudinal rebar. - MatPropConfine
- Type: SystemString
The name of the rebar material property for the confinement rebar. - CoverTop
- Type: SystemDouble
The distance from the top of the beam to the centroid of the top
longitudinal reinforcement. [L] - CoverBot
- Type: SystemDouble
The distance from the bottom of the beam to the centroid of the
bottom longitudinal reinforcement. [L] - TopLeftArea
- Type: SystemDouble
The total area of longitudinal reinforcement at the
top left end of the beam. [L2] - TopRightArea
- Type: SystemDouble
The total area of longitudinal reinforcement at the
top right end of the beam. [L2] - BotLeftArea
- Type: SystemDouble
The total area of longitudinal reinforcement at the
bottom left end of the beam. [L2] - BotRightArea
- Type: SystemDouble
The total area of longitudinal reinforcement at the
bottom right end of the beam. [L2]
Return Value
Type:
Int32Returns zero if the rebar data is successfully assigned;
otherwise it returns a nonzero value.
Remarks
This function applies only to the following section types. Calling this function for any other type of frame section property returns an error.
The material assigned to the specified frame section property must be concrete or this function returns an error.
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim RebarName As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropFrame.SetRectangle("R1", "4000Psi", 20, 12)
ret = SapModel.PropMaterial.AddQuick(RebarName, eMatType.Rebar, , , , , eMatTypeRebar.ASTM_A706)
ret = SapModel.PropFrame.SetRebarBeam("R1", RebarName, RebarName, 3.5, 3, 4.1, 4.2, 4.3, 4.4)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also