cPropFrameCount Method

Retrieves the total number of defined frame section properties in the model.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int Count(
	eFramePropType PropType = 
)

Parameters

PropType (Optional)
Type: ETABS2016eFramePropType
This optional value is one of the items in the eFramePropType enumeration.

If no value is input for PropType, a count is returned for all frame section properties in the model regardless of type.

Return Value

Type: Int32
Returns the total number of defined frame section properties in the model. If desired, counts can be returned for all frame section properties of a specified type in the model.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim Count As Integer

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'return number of defined frame section properties of all types
       Count = SapModel.PropFrame.Count

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also