cPointObjGetCoordCartesian Method |
Retrieves the x, y and z coordinates of the specified point object
in the Present Units.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetCoordCartesian(
string Name,
ref double X,
ref double Y,
ref double Z,
string CSys = "Global"
)
Function GetCoordCartesian (
Name As String,
ByRef X As Double,
ByRef Y As Double,
ByRef Z As Double,
Optional CSys As String = "Global"
) As Integer
int GetCoordCartesian(
String^ Name,
double% X,
double% Y,
double% Z,
String^ CSys = L"Global"
)
abstract GetCoordCartesian :
Name : string *
X : float byref *
Y : float byref *
Z : float byref *
?CSys : string
(* Defaults:
let _CSys = defaultArg CSys "Global"
*)
-> int
Parameters
- Name
- Type: SystemString
The name of a defined point object.
- X
- Type: SystemDouble
- Y
- Type: SystemDouble
- Z
- Type: SystemDouble
- CSys (Optional)
- Type: SystemString
The name of a defined coordinate system. If Csys is not specified,
the Global coordinate system is assumed.
Return Value
Type:
Int32
Returns zero if the coordinates are successfully returned;
otherwise it returns nonzero.
Remarks
The coordinates are reported in the coordinate system specified
by
CSys.
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim x As Double, y As Double, z As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.PointObj.GetCoordCartesian("1", x, y, z)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also