cAnalysisResultsPierForce Method |
Retrieves pier forces for any defined pier objects in the model
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint PierForce(
ref int NumberResults,
ref string[] StoryName,
ref string[] PierName,
ref string[] LoadCase,
ref string[] Location,
ref double[] P,
ref double[] V2,
ref double[] V3,
ref double[] T,
ref double[] M2,
ref double[] M3
)
Function PierForce (
ByRef NumberResults As Integer,
ByRef StoryName As String(),
ByRef PierName As String(),
ByRef LoadCase As String(),
ByRef Location As String(),
ByRef P As Double(),
ByRef V2 As Double(),
ByRef V3 As Double(),
ByRef T As Double(),
ByRef M2 As Double(),
ByRef M3 As Double()
) As Integer
int PierForce(
int% NumberResults,
array<String^>^% StoryName,
array<String^>^% PierName,
array<String^>^% LoadCase,
array<String^>^% Location,
array<double>^% P,
array<double>^% V2,
array<double>^% V3,
array<double>^% T,
array<double>^% M2,
array<double>^% M3
)
abstract PierForce :
NumberResults : int byref *
StoryName : string[] byref *
PierName : string[] byref *
LoadCase : string[] byref *
Location : string[] byref *
P : float[] byref *
V2 : float[] byref *
V3 : float[] byref *
T : float[] byref *
M2 : float[] byref *
M3 : float[] byref -> int
Parameters
- NumberResults
- Type: SystemInt32
The total number of results returned by the program
- StoryName
- Type: SystemString
The story name of the pier object
- PierName
- Type: SystemString
The name of the pier object
- LoadCase
- Type: SystemString
The names of the load case
- Location
- Type: SystemString
The location on the pier, either "Top" or "Bottom", of the result being reported
- P
- Type: SystemDouble
The axial force [F]
- V2
- Type: SystemDouble
The shear force in the local 2 direction [F]
- V3
- Type: SystemDouble
The shear force in the local 3 direction [F]
- T
- Type: SystemDouble
The torsion [FL]
- M2
- Type: SystemDouble
The moment about the local 2 axis [FL]
- M3
- Type: SystemDouble
The moment about the local 3 axis [FL]
Return Value
Type:
Int32
Returns zero if the results are successfully retrieved; otherwise returns nonzero
Remarks
See Also