cPropFrameGetRectangle Method |
Retrieves frame section property data for a rectangular frame section.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetRectangle(
string Name,
ref string FileName,
ref string MatProp,
ref double T3,
ref double T2,
ref int Color,
ref string Notes,
ref string GUID
)
Function GetRectangle (
Name As String,
ByRef FileName As String,
ByRef MatProp As String,
ByRef T3 As Double,
ByRef T2 As Double,
ByRef Color As Integer,
ByRef Notes As String,
ByRef GUID As String
) As Integer
int GetRectangle(
String^ Name,
String^% FileName,
String^% MatProp,
double% T3,
double% T2,
int% Color,
String^% Notes,
String^% GUID
)
abstract GetRectangle :
Name : string *
FileName : string byref *
MatProp : string byref *
T3 : float byref *
T2 : float byref *
Color : int byref *
Notes : string byref *
GUID : string byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing or new frame section. - FileName
- Type: SystemString
If the section property was imported from a property file,
this is the name of that file. If the section property was not imported, this item is blank. - MatProp
- Type: SystemString
The name of the material property for the section. - T3
- Type: SystemDouble
- T2
- Type: SystemDouble
- Color
- Type: SystemInt32
- Notes
- Type: SystemString
- GUID
- Type: SystemString
The GUID (global unique identifier), if any, assigned to the section.
Return Value
Type:
Int32Returns zero if the section property is successfully retrieved;
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim FileName As String
Dim MatProp As String
Dim t3 As Double
Dim t2 As Double
Dim Color As Integer
Dim Notes As String
Dim GUID As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropFrame.SetRectangle("R1", "4000Psi", 20, 12)
ret = SapModel.PropFrame.GetRectangle("R1", FileName, MatProp, t3, t2, Color, Notes, GUID)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also