cFrameObjSetLoadPoint Method |
Assigns point loads to frame objects.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetLoadPoint(
string Name,
string LoadPat,
int MyType,
int Dir,
double Dist,
double Val,
string CSys = "Global",
bool RelDist = true,
bool Replace = true,
eItemType ItemType = eItemType.Objects
)
Function SetLoadPoint (
Name As String,
LoadPat As String,
MyType As Integer,
Dir As Integer,
Dist As Double,
Val As Double,
Optional CSys As String = "Global",
Optional RelDist As Boolean = true,
Optional Replace As Boolean = true,
Optional ItemType As eItemType = eItemType.Objects
) As Integer
int SetLoadPoint(
String^ Name,
String^ LoadPat,
int MyType,
int Dir,
double Dist,
double Val,
String^ CSys = L"Global",
bool RelDist = true,
bool Replace = true,
eItemType ItemType = eItemType::Objects
)
abstract SetLoadPoint :
Name : string *
LoadPat : string *
MyType : int *
Dir : int *
Dist : float *
Val : float *
?CSys : string *
?RelDist : bool *
?Replace : bool *
?ItemType : eItemType
(* Defaults:
let _CSys = defaultArg CSys "Global"
let _RelDist = defaultArg RelDist true
let _Replace = defaultArg Replace true
let _ItemType = defaultArg ItemType eItemType.Objects
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing frame object or group, depending on the
value of the ItemType item.
- LoadPat
- Type: SystemString
The name of a defined load pattern.
- MyType
- Type: SystemInt32
This is 1 or 2, indicating the type of point load.
- Force
- Moment
- Dir
- Type: SystemInt32
This is an integer between 1 and 11, indicating the direction of the load.
- Local 1 axis (only applies when CSys is Local)
- Local 2 axis (only applies when CSys is Local)
- Local 3 axis (only applies when CSys is Local)
- X direction (does not apply when CSys is Local)
- Y direction (does not apply when CSys is Local)
- Z direction (does not apply when CSys is Local)
- Projected X direction (does not apply when CSys is Local)
- Projected Y direction (does not apply when CSys is Local)
- Projected Z direction (does not apply when CSys is Local)
- Gravity direction (only applies when CSys is Global)
- Projected Gravity direction (only applies when CSys is Global)
The positive gravity direction (see Dir = 10 and 11) is in
the negative Global Z direction.
- Dist
- Type: SystemDouble
- Val
- Type: SystemDouble
- CSys (Optional)
- Type: SystemString
This is Local or the name of a defined coordinate system.
It is the coordinate system in which the loads are specified.
- RelDist (Optional)
- Type: SystemBoolean
If this item is True, the specified dist
item is a relative distance, otherwise it is an actual distance.
- Replace (Optional)
- Type: SystemBoolean
If this item is True, all previous loads, if any,
assigned to the specified frame object(s), in the specified load pattern,
are deleted before making the new assignment.
- ItemType (Optional)
- Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the assignment is made to the frame object
specified by the Name item.
If this item is Group, the assignment is made to all frame objects
in the group specified by the Name item.
If this item is SelectedObjects, the assignment is made to all
selected frame objects and the Name item is ignored.
Return Value
Type:
Int32
Returns zero if the loads are successfully assigned,
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.FrameObj.SetLoadPoint("15", "DEAD", 1, 10, .5, 20)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also