cPointObjSetSpecialPoint Method

Sets the special point status for a point object.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int SetSpecialPoint(
	string Name,
	bool SpecialPoint,
	eItemType ItemType = eItemType.Objects
)

Parameters

Name
Type: SystemString
The name of an existing point object or group depending on the value of the ItemType item.
SpecialPoint
Type: SystemBoolean
This item is True if the point object is specified as a special point, otherwise it is False.
ItemType (Optional)
Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
  • Object = 0
  • Group = 1
  • SelectedObjects = 2

If this item is Objects, the special point status is set for the point object specified by the Name item.

If this item is Group, the special point status is set for all point objects in the group specified by the Name item.

If this item is SelectedObjects, the special point status is set for all selected point objects and the Name item is ignored.

Return Value

Type: Int32
Returns zero if the special point status is successfully set, otherwise it returns a nonzero value.
Remarks
Special points are allowed to exist in the model even if no objects (line, area, solid, link) are connected to them. Points that are not special are automatically deleted if no objects connect to them.
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)

   'set as special point
       ret = SapModel.PointObj.SetSpecialPoint("3", True)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also