cPropFrameGetModifiers Method |
Retrieves the modifier assignments for a frame section property.
The default value for all modifiers is one.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetModifiers(
string Name,
ref double[] Value
)
Function GetModifiers (
Name As String,
ByRef Value As Double()
) As Integer
int GetModifiers(
String^ Name,
array<double>^% Value
)
abstract GetModifiers :
Name : string *
Value : float[] byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing frame section property. - Value
- Type: SystemDouble
This is an array of eight unitless modifiers:
Value | Modifier |
---|
Value(0) | Cross sectional area modifier |
Value(1) | Shear area in local 2 direction modifier |
Value(2) | Shear area in local 3 direction modifier |
Value(3) | Torsional constant modifier |
Value(4) | Moment of inertia about local 2 axis modifier |
Value(5) | Moment of inertia about local 3 axis modifier |
Value(6) | Mass modifier |
Value(7) | Weight modifier |
Return Value
Type:
Int32Returns zero if the modifier assignments are successfully retrieved;
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim i As Integer
Dim Value() As Double
Dim MyValue() As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropFrame.SetISection("ISEC1", "A992Fy50", 24, 10, 0.5, 0.3, 14, 0.6)
ReDim Value(7)
For i = 0 To 7
Value(i) = 1
Next i
Value(5) = 100
ret = SapModel.PropFrame.SetModifiers("ISEC1", Value)
ret = SapModel.PropFrame.GetModifiers("ISEC1", MyValue)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also